hdu4268 Alice and Bob,multiset

Alice and Bob

Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
  
  
1 2
 

题意:

有童鞋A 和 童鞋B

A想用手里的牌尽量多地覆盖掉B手中的牌..

给出了T表示有T组样例..

每组样例给出一个n 表示A和B手中都有n张牌

接下来2*n行 有h w 分别代表A手中n张牌的高和宽 以及 B手中n张牌的高和宽

问A手中的牌最多能覆盖B多少张牌



Sort、 Multiset


#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100000 + 10;
struct Node {
    int w, h;
    bool operator < (const Node& rhs) const
    {
        return w < rhs.w;
    }
};

Node A[maxn], B[maxn];

multiset<int> ms;
multiset<int>::iterator it;
int n;

int main()
{
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        for(int i=0; i<n; ++i) {
            scanf("%d%d", &A[i].w, &A[i].h);
        }
        for(int i=0; i<n; ++i) {
            scanf("%d%d", &B[i].w, &B[i].h);
        }

        sort(A, A+n);
        sort(B, B+n);
        int ans = 0;
        ms.clear();

        for(int i=0, j=0; i<n; ++i) {
            while(j<n&&A[i].w>=B[j].w) {
                ms.insert(B[j++].h);
            }
            if(ms.empty()) continue;
            it = ms.upper_bound(A[i].h);
            if(it != ms.begin()) {
                ms.erase(--it);
                ans++;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值