1004 Counting Leaves (30分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
思路:其实就是写一个在线算法,使每一步阶层都需要更新。
为什么要整理:一开始只得了16分,原因在于,我个人认为每一个父节点初始层数都是0,其实不然,他其实可以已经是别人的儿子或者孙子,再来当你的爸爸,加一个parent即可。
说明:本题思路纯属个人当思维题做的,全网无第二份。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXN 115
struct node
{
int grade,parent;
vector<int> child;
};
int n,m,res[MAXN];
node a[MAXN];
void change(int p)
{
int parent = a[p].parent;
a[p].grade = a[parent].grade + 1;
for(int i = 0; i < a[p].child.size(); i++)
{
int temp = a[p].child[i];
change(temp);
}
return;
}
int main()
{
int p,k,c,max_grade;
while(scanf("%d %d",&n,&m) != EOF)
{
max_grade = 0;
for(int i = 0; i < 102; i++) res[i] = 0;
for(int i = 0; i < 102; i++) a[i].grade = 0;
for(int i = 0; i < m; i++)
{
scanf("%d %d",&p,&k);
for(int j = 0; j < k; j++)
{
scanf("%d",&c);
a[p].child.push_back(c);
a[c].parent = p;
change(c);
}
}
for(int i = 1; i <= n; i++)
{
max_grade = max(max_grade,a[i].grade);
if(a[i].child.empty()) res[a[i].grade]++;
}
bool flag = false;
for(int i = 0; i <= max_grade; i++)
{
if(!flag)
{
flag = true;
printf("%d",res[i]);
}
else printf(" %d",res[i]);
}
puts("");
}
return 0;
}