(PAT 1004) Counting Leaves (树的广度优先)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

解题思路:

先把树建起来,然后利用广度优先遍历,统计每一层中叶子结点的个数(保存到哈对应的哈希表中),最后输出哈希表

我们在广度优先遍历时可以保存层数

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <string>
#include <string.h>
using namespace std;
int hashTable[1010];
int N, M;
int Depth = 0;
struct FNode{
	vector<int> child;
}FTree[1010];

void BFS_F(int root) {
	queue<int> bfs_tree;
	queue<int> bfs_layer;
	bfs_layer.push(0);
	bfs_tree.push(root);
	while (!bfs_tree.empty()) {
		int curLayer = bfs_layer.front();
		int curNode = bfs_tree.front();
		if (FTree[curNode].child.empty()) {
			hashTable[curLayer]++;
		}
		Depth = curLayer;
		bfs_tree.pop();
		bfs_layer.pop();
		for (auto x : FTree[curNode].child) {
			bfs_tree.push(x);
			bfs_layer.push(curLayer + 1);
		}
	}
}
int main() {
	memset(hashTable, 0, sizeof(hashTable));
	scanf("%d %d", &N, &M);
	for (int i = 0; i < M; ++i) {
		int ID,k;
		scanf("%d %d", &ID,&k);
		for (int j = 0; j < k; ++j) {
			int chi;
			scanf("%d", &chi);
			FTree[ID].child.push_back(chi);
		}
	}
	BFS_F(1);
	for (int i = 0; i <= Depth; ++i) {
		printf("%d", hashTable[i]);
		if (i < Depth) printf(" ");
	}
	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值