1004 Counting Leaves (30 分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
题意:给你个族系谱,找出每一层中没有孩子(叶子节点)的个数
解析:利用深度优先遍历,从起点开始,一直到没有子树,说明它是个叶子节点,也就是没有孩子。
num[i]表示i层没有孩子的个数
#include<bits/stdc++.h>
using namespace std;
#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}
const int maxn=105;
vector<int> ve[maxn];
int num[maxn];
int n,m,maxdep=-1;
void dfs(int node,int dep)
{
if(ve[node].size()==0)
{
num[dep]++;
maxdep=max(maxdep,dep);
return ;
}
for(int i=0; i<ve[node].size(); i++)
{
dfs(ve[node][i],dep+1);
}
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=0; i<m; i++)
{
int node,k;scanf("%d%d",&node,&k);
for(int j=0; j<k; j++)
{
int x;scanf("%d",&x);
ve[node].push_back(x);
}
}
dfs(1,0);
printf("%d",num[0]);
for(int i=1; i<=maxdep; i++)
{
printf(" %d",num[i]);
}
puts("");
return 0;
}