hdu 1102A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L
这类型的题以前做过,就没做了,今天学弟让我找bug,找了老半天结果是输出问题,无语。我发现我们找bug总是先找算法错误,这也算是个提醒吧,先看数据结构,再看输出,最后看算法!

思路:把两个字符型的从对应的最后位置开始相加,开个数组保留中间结果,思路应该还是好想到的!

#include<stdio.h>
#include<string.h> 
int main()
{
    int lena, lenb, m, i, j, l, jzs, c, wsh, k[10006], sum, ll;
    char a[10006], b[10006];
    scanf("%d",&sum);
    for(ll = 0; ll < sum; ll++)
    {
        scanf("%s",a);
        scanf("%s",b);
        memset(k,0,sizeof(k));
        lena = strlen(a);
        lenb = strlen(b);
        if(lena < lenb)//对长点的字串控制下
        {  
               char t[10006]; 
            strcpy(t, b);
            strcpy(b, a);
            strcpy(a,t);
            m = lenb;
            lenb = lena;
            lena = m;
        }

        jzs = 0;//进位
        l = 0;
        for(i = lena-1, j = lenb-1; j != -1; i--, j--)
        {
            wsh = (a[i]-'0')+(b[j]-'0')+jzs;//本位
            if(wsh > 9)
            {
                jzs = 1;
                wsh = wsh%10;
            }
            else jzs = 0;
            k[l] = wsh;
            l++;
        }

        for(; i != -1; i--)
        {
            wsh = (a[i] - '0')+jzs;
            if(wsh > 9)
            {
                jzs = 1;
                wsh = wsh%10;
            }
            else jzs = 0;
            k[l] = wsh;
            l++;
        }

        if(jzs == 1)
        {
            k[l] = 1;
            l++;
        }

        printf("Case %d:\n",ll+1);
        printf("%s + %s = ",a,b);
        for(c = l-1; c != -1; c--)
        {
            printf("%d",k[c]); 
        }
        printf("\n");
        if(ll!=sum-1)
        printf("\n");
    }

    return 0 ;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值