A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<fstream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<stack>
using namespace std;
stack<int> F(string s1, string s2)
{
	reverse(s1.begin(), s1.end());
	reverse(s2.begin(), s2.end());
	stack<int> St;
	size_t index1 = 0, index2 = 0;
	int J = 0;
	while (index1 < s1.size() && index2 < s2.size()) {
		int sum = (s1[index1++] - '0') + (s2[index2++] - '0') + J;
		St.push(sum % 10);
		J = sum / 10;
	}
	while (index1 < s1.size()) {
		int sum = (s1[index1++] - '0') + J;
		St.push(sum % 10);
		J = sum / 10;
	}
	while (index2 < s2.size()) {
		int sum = (s2[index2++] - '0') + J;
		St.push(sum % 10);
		J = sum / 10;
	}
	if (J > 0) {
		St.push(J);
	}
	
	return St;
}
int main()
{
//	ifstream inFile("C:\\Users\\DELL\\Desktop\\in.txt");
	string s1,s2;
	int N;
	cin >> N;
	for (int i = 0; i < N; ++i) {
		cout << "Case " << i + 1 << ":" << endl;
		cin >> s1 >> s2;
		stack<int> St=F(s1, s2);
		cout << s1 << " + " << s2 << " = ";
		while (St.size()) {
			cout << St.top();
			St.pop();
		}
		cout << endl;
		if (i != N-1) {
			cout << endl;
		}
	}
	
//	inFile.close();
	system("pause");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值