1046 Shortest Distance (20 分)(前缀和问题)

42 篇文章 0 订阅
26 篇文章 0 订阅

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

其实题目的意思挺简单的。。。

一开始用的邻接表+spfa,第三组段错误。。不知道为啥。。

应该出题的意思不是让你用这个方法吧。。

然后用的前缀和。可以的。。(只不过一开始没有想到。。。)

AC代码:

 #include <bits/stdc++.h>
///就两条路,求前缀题目,意思是数组的某个位置上的数,
///存的是在此之前的所有的数的和。
using namespace std;
int main()
{
    int n;
    int a[100005];
    long long pre[100005];///前缀。
    long long sum = 0;///总和。
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        sum += a[i];
        pre[i] += (pre[i-1] + a[i]);
    }
    int q;
    int u,v;
    scanf("%d",&q);
    while(q--)
    {
        scanf("%d%d",&u,&v);
        if(u>v)
        {
            int t = u;
            u = v;
            v = t;
        }
        long long mn = min(pre[v-1]-pre[u-1],sum-pre[v-1]+pre[u-1]);
        printf("%lld\n",mn);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值