1046 Shortest Distance (20 point(s))
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤ 104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
题目大意:
有 N 个出口,成环分布,分别给出相邻两个出口的距离,对于 M 次查询,给出两个出口间的最短距离
设计思路:
- 用数组储存每个节点到第 1 个节点的总距离,dis[n] 的值等于整个环路的总距离,
- 所求结果等于两出口 dis[num2 - 1] - dis[num1 - 1] 和 dis[n] - (dis[num2 - 1] - dis[num1 - 1]) 之间的较小值
编译器:C (gcc)
#include <stdio.h>
int main(void)
{
int n, m;
int dis[100001] = {0};
int i, temp, num1, num2, dis1, dis2;
scanf("%d", &n);
for (i = 1; i <= n; i++) {
scanf("%d", &temp);
dis[i] = dis[i - 1] + temp;
}
scanf("%d", &m);
for (i = 0; i < m; i++) {
scanf("%d %d", &num1, &num2);
if (num1 > num2) {
temp = num1;
num1 = num2;
num2 = temp;
}
dis1 = dis[num2 - 1] - dis[num1 - 1];
dis2 = dis[n] - dis1;
printf("%d\n", dis1 <= dis2 ? dis1 : dis2);
}
return 0;
}