HDU 1237 简单计算器

简单计算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14753    Accepted Submission(s): 5014


Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
 
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
 
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
 
Sample Input
  
  
1 + 2 4 + 2 * 5 - 7 / 11 0
 
Sample Output
  
  
3.00 13.36
 
 这题主要是考对栈的操作,题比较水。如果是大牛就请直接绕道吧,毕竟本文主要针对数据结构不太精通的群体,本人几个月前曾在博客上发表一篇关于 MFC 实现 加减乘除,括号,乘方的 计算器  ,那里涉及的操作相对更加复杂,大家也可以参考那里看一看。话不多说,上代码吧! 如果大家不能理解代码,可以参考我写的MFC计算器的博客,那个讲解很详细的。
顺便提醒一下,这个题目float不能过,试一试double吧!亲身尝试了 哭
#include <queue>
#include <cctype>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 200+5;
stack<double> Num;
stack<char> Op;
string buf;
int main() {
    //freopen("input.in","r",stdin);
    while(getline(cin,buf)) {
        if(buf == "0") break;
        if(buf == "") continue;
        while(!Num.empty()) Num.pop();
        while(!Op.empty()) Op.pop();
        for(int i = 0;i < buf.length();i++) {
            if(buf[i] == ' ') continue;
            else if(buf[i] >= '0' && buf[i] <= '9') {
                int j,ep = i;char sztmp[maxn];
                for( j = 0;j+i < buf.length();j++) {
                    if(buf[i+j]>='0'&&buf[i+j]<='9') { sztmp[j]=buf[i+j];ep++; }
                    else break;
                }
                sztmp[j]='\0';
                double ntmp = atof(sztmp);
                Num.push(ntmp);
                i = ep;
            }
            else if(buf[i] == '*' || buf[i] == '/') {
                if(Op.empty()) { Op.push(buf[i]); continue; }
                if(Op.top() == '+'||Op.top() == '-') {  Op.push(buf[i]);continue; }
                while(!Op.empty()&&(Op.top() == '*'||Op.top() == '/')){
                    double l,r;char c;
                    c = Op.top();Op.pop();
                    r = Num.top();Num.pop();
                    l = Num.top();Num.pop();
                    if(c == '*') Num.push(l*r);
                    else if(c== '/')Num.push(l/r);
                }
                Op.push(buf[i]);
            }
            else if(buf[i] == '+' || buf[i] == '-'){
                if(Op.empty()) { Op.push(buf[i]); continue; }
                while(!Op.empty()){
                    double l,r;char c;
                    c = Op.top();Op.pop();
                    r = Num.top();Num.pop();
                    l = Num.top();Num.pop();
                    if(c == '+') Num.push(l+r);
                    else if(c== '-')Num.push(l-r);
                    else if(c == '*') Num.push(l*r);
                    else if(c== '/')Num.push(l/r);
                }
                Op.push(buf[i]);
            }
        }
        while(!Op.empty()){
            double l,r;char c;
            c = Op.top();Op.pop();
            r = Num.top();Num.pop();
            l = Num.top();Num.pop();
            if(c == '*') Num.push(l*r);
            else if(c== '/')Num.push(l/r);
            else if(c == '+')Num.push(l+r);
            else if(c == '-')Num.push(l-r);
        }
        double ans = Num.top();Num.pop();
        printf("%.2lf\n",ans);
    }
    return 0;
}

转载请注明出处,谢谢! http://blog.csdn.net/acmore_xiong?viewmode=contents~
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值