pushpush

5 篇文章 0 订阅
4 篇文章 0 订阅

题目描述

You are given an integer sequence of length n, a1,…,an. Let us consider performing the following n operations on an empty sequence b.
The i-th operation is as follows:
1.Append ai to the end of b.
2.Reverse the order of the elements in b.
Find the sequence b obtained after these n operations.

Constraints
1≤n≤2×105
0≤ai≤109
n and ai are integers.

输入

Input is given from Standard Input in the following format:
n
a1 a2 … an

输出

Print n integers in a line with spaces in between. The i-th integer should be bi.

样例输入

4
1 2 3 4

样例输出

4 2 1 3

提示

After step 1 of the first operation, b becomes: 1.
After step 2 of the first operation, b becomes: 1.
After step 1 of the second operation, b becomes: 1,2.
After step 2 of the second operation, b becomes: 2,1.
After step 1 of the third operation, b becomes: 2,1,3.
After step 2 of the third operation, b becomes: 3,1,2.
After step 1 of the fourth operation, b becomes: 3,1,2,4.
After step 2 of the fourth operation, b becomes: 4,2,1,3.
Thus, the answer is 4 2 1 3.

规律:a[n] . a[n-2] . a[n-4] . ...a[n-5] . a[n-3] . a[n-1]

代码如下:

#include <bits/stdc++.h>
using namespace std;
#define ll long long
#define pre(i,x,n) for(int i=x;i<=n;i++)
int n,a[200010],b[200010];
int main()
{
    int head=1,tail,temp=1;
    scanf("%d",&n);
    tail=n;
    for(int i=1;i<=n;i++)
      scanf("%d",&a[i]);
    for(int i=n;i>0;i--)
    {
        if(temp)
        {
           b[head]=a[i];
           head++;
           temp=!temp;
        }
        else
        {
           b[tail]=a[i];
           tail--;
           temp=!temp;
        }
    }
    printf("%d",b[1]);
    for(int i=2;i<=n;i++)
      printf(" %d",b[i]);
    putchar('\n');
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

2020/3/16

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值