Tallest Cow 最高的牛

题目:

FJ's N (1 <= N <= 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 <= H <= 1,000,000) of the tallest cow along with the index I of that cow. FJ has made a list of R (0 <= R <= 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17. For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

* Line 1: Four space-separated integers: N, I, H and R

 * Lines 2..R+1: Two distinct space-separated integers A and B (1 <= A, B <= N), indicating that cow A can see cow B.

Output

* Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5 
1 3 
5 3 
4 3 
3 7 
9 8 


INPUT DETAILS: 

There are 9 cows, and the 3rd is the tallest with height 5. 

Sample Output









翻译:

有n(1 <= n <= 10000)头牛从1到n线性排列,每头牛的高度为h[i](1 <= i <= n),现在告诉你这里面的牛的最大高度为maxH,而且有r组关系,每组关系输入两个数字,假设为a和b,表示第a头牛能看到第b头牛,能看到的条件是a, b之间的其它牛的高度都严格小于min(h[a], h[b]),而h[b] >= h[a]。要输出满足条件且所有牛的高度和最大的一组情况。

分析:我们思考一个问题,假如i<j,要求i能看见j,那么j能否看到i和j中间的任何一头牛?答案是一定看不到的,i能看见j,说明h[i]<=h[j],且i和j中间的牛的高度都低于h[j],所以j肯定看不到i和j中间的牛,而j有可能看到i及i左边的牛。我们怎样处理这种条件关系呢?由于题目中求的是满足条件且所有牛的高度和最大的一组情况,所以我们可以先假设所有牛的高度均为最大值,对于可视条件我们先想一种暴力做法,就是假如i可以看到j,那么我们就令i和j中间的牛(不包括i和j)的高度均减1,直到处理完所有的条件就可以了,但这样复杂度太高了,既然是在一个静态区间上进行加操作和减操作,那么我们就可以用差分数组来进行实现,每次对于区间[i+1,j-1]的区间上进行-1操作,我们可以令差分数组d[i+1]-1,d[j]+1,这样就可以O(1)实现区间上的减操作了,这样总的复杂度就是条件的个数。需要注意的一点是对于同一个条件出现多次的情况,我们只需要处理一次即可。

下面是代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<cmath>
using namespace std;
map<pair<int,int>,bool> vis;//设置一个map记录当前比较是否重复 
const int N=12000;
int d[N];//记录高度差分数组 
int main()
{
	int n,idx,h,r;
	cin>>n>>idx>>h>>r;
	int ll,rr;
	while(r--)
	{
		scanf("%d%d",&ll,&rr);
		if(ll>rr) swap(ll,rr);
		if(vis[make_pair(ll,rr)]) continue;
		vis[make_pair(ll,rr)]=true;
		d[ll+1]--;d[rr]++;
	}
	d[0]=h;//设置所有高度均为最大值 
	for(int i=1;i<=n;i++)
	{
		d[i]+=d[i-1];
		printf("%d\n",d[i]);
	}
	return 0; 
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值