POJ 2002 Squares

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

Rocky Mountain 2004

/* 
      题目大意是在二维平面坐标中给定N个点,然后通过查找的方式找出其中有多少个正方形。


     解决方法用的是STL中的set函数,用pair将坐标作为一个数据类型存放在set中,然后每次枚举两个点,判断正方形的其他两个点是否存在。
*/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <stack>
#include <cmath>
#include <cstdio>
#include <vector>
#include <queue>
#include <set>
using namespace std;

struct node
{
    int x,y;
}a[1010];

int f(int x1,int y1)
{
    return (x1+y1)/2;
}

int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        set<pair<int,int> >s;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].x*=2;a[i].y*=2; //将每个点*2处理,防止之后的浮点数
            s.insert(pair<int,int>(a[i].x,a[i].y)); //存入set
        }
        int sum = 0;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                int x = f(a[i].x,a[j].x); //求中点横坐标
                int y = f(a[i].y,a[j].y); //求中点竖坐标
                if(s.find(pair<int,int>(x+(-1*(a[i].y-y)),y+(a[i].x-x)))!=s.end() && s.find(pair<int,int>(x-(-1*(a[i].y-y)),y-(a[i].x-x)))!=s.end()) //判断两个点是否存在
                {
                    sum++;
                }
            }
        }
        printf("%d\n",sum/2);//因为枚举两个点的时候,正方形有两个对角线,每个正方形会遇到两次,所以除以2
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值