POJ 3258 River Hopscotch (二分)

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11291 Accepted: 4837

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to Mrocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目大意:
有一条很宽很宽的河,最宽为L米,河里最多有N块石头。问题是有群牛要过河,一个丧心病狂的人想知道牛最多会跳多远。然后给你N个石头的位置,给定的N个整数是每个石头离岸边的距离,然后问你去掉其中的M个之后,对于每种石头的分布方式,找出牛需要跳的距离中最小的最大值为多少。
hiht中把2 14两块石头去掉了之后变为4

解题思路:
很明显的二分,因为L实在是太大,只能从N着想,二分0 - L为答案,然后判断去掉m个石头是否能满足现状,找出符合条件的最小即可。

#include <algorithm>
#include <iostream>
#include <numeric>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <cstdio>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const LL MAX = 405;
const double esp = 1e-6;
const double PI = 3.1415926535898;
const int INF = 0x3f3f3f3f;
using namespace std;
int arr[50005];

bool cal(int x,int n,int m){
    int last = 0,tot = 0;
    for(int i=1;i<=n;i++){
        if(arr[i] - arr[last] < x){
            tot += 1;
            if(tot > m)
                return false;
        }
        else
            last = i;
    }
    return true;
}

int main(){
    int L,n,m;
    while(~scanf("%d %d %d",&L,&n,&m)){
        for(int i=1;i<=n;i++){
            scanf("%d",&arr[i]);
        }
        sort(arr+1,arr+1+n);
        int l = 0,r = L;
        while(l <= r){
            int mid = (l + r) / 2;
            if(cal(mid,n,m))
                l = mid + 1;
            else
                r = mid - 1;
        }
        printf("%d\n",l - 1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值