【POJ】3258River Hopscotch(二分求最大化最小值)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22178 Accepted: 9168

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of Mrocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver

题目大意:现在有一条河,和一个牛,这个牛必须要踩在这个河中的石子上才能过去,现在给你这个N个石子的位置(一条直线上),现在我们想要把石子的数量减少M个,问你减少M个之后的牛能走的石头间距最小值中,最大的那一个是多少

思路:也就是最大化最小值了,二分解决这个问题。

首先:我们知道这个牛跳到石子上是没有限制的(哪怕是直接跳到对岸。。。),也就是说我们枚举的上限距离就是河的宽度,

然后枚举距离进行二分,每次枚举一个mid距离,然后我们用这个距离来check,需要check的东西也就是当我使用这个距离为题中需要的最小距离,用这个距离来判断需要删去的石子。

其中如果当我们枚举到一个mid距离,而用这个距离为最小距离时需要删去的石子数量是比M还要多的时候,也就说明这个时候我们的mid还是大,反之mid小

其中去掉石子的时候,我们可以模拟这个用最小距离过河的过程,用一个start表示牛每次踩的石子,。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=100010;
int a[maxn];
int n,m,l;
bool check(int mid)
{
    int start=0,cnt=0;
    for(int i=1;i<=n;i++)
    {
        if(a[i]-start<mid)
            cnt++;
        else
            start=a[i];
    }
    if(l-a[n]<mid) return false;

    if(cnt>m) //需要删除的点多余M说明走的距离mid过大了
        return false ;
    return true;

}
int main()
{
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        int left=0,right=l;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        int ans;
        while(left<=right)
        {
            int mid=(left+right)/2;
            if(check(mid))
            {
                ans=mid;
                left=mid+1;
            }
            else
                right=mid-1;
        }
        cout<<ans<<endl;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值