[Poj 1129] Channel Allocation DFS+四色定理剪支

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13861 Accepted: 7076

Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,…,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed.

题意:
一个有N个节点的无向图,要求对每个节点进行染色,使得相邻两个节点颜色都不同,问最少需要多少种颜色?
题解:
任何平面地图可以只用四个颜色着色—四色定理;
即本题COLOR最多4种颜色;

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
char str[33];
int id[35];
int ma[33][33];
int ans;
bool can(int x,int y)
{
    //cout<<x<<"  "<<y<<endl;
    //if(x==3&&y==1) cout<<ma[1][3]<<endl;
    for(int i=1;i<=n;i++)
    if(i!=x&&ma[i][x]==1&&y==id[i])
    {
        //cout<<"   "<<"sb"<<endl;
        return 0;
    }
    return 1;
}
void dfs(int x)
{
    //cout<<x<<endl;
    if(*max_element(id+1,id+1+n)>=ans) return;
    if(x==n+1) 
    {
        ans=min(ans,*max_element(id+1,id+1+n));
        return ;
    }
    for(int j=x;j<=n;j++)
    for(int i=1;i<=4;i++)   
    {
        if(can(j,i))
        {
            id[j]=i;
            dfs(j+1);
        }

    }

}
int main()
{   
    while(scanf("%d",&n))
    {
        if(n==0) return 0;
        memset(ma,0,sizeof(ma));
        for(int i=1;i<=n;i++)
        {
            scanf("%s",str);
            int len=strlen(str);
            str[len]='\0';
            for(int j=2;j<len;j++)
            {
                ma[i][str[j]-'A'+1]=1;
                ma[str[j]-'A'+1][j]=1;
            }
        }
        ans=4;
        memset(id,0,sizeof(id));
        id[1]=1;
        dfs(2);
        if(ans==1)
        {
            printf("1 channel needed.\n");
        }
        else printf("%d channels needed.\n",ans);
    }


}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值