【poj 2479】Maximum sum DP

Language:
Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37722 Accepted: 11788

Description
Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.

Output
Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

Source
POJ Contest,Author:Mathematica@ZSU

题目链接http://poj.org/problem?id=2479
题意:给定n个数,求两段连续不重叠子段的最大和。比如1 -1 2 2 3 -3 4 -4 5 -5结果就是 {2,2,3,-3,4} 和 {5},也就是两者的和13。
思路:dp求求最大字段和的状态转移方程:b[j] = max {b[j-1] + a[j], a[j]}, 1 <= j <= n。

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int a[50005],b[50005];
int aa[50005];
int dp1[50005],dp2[50005];
int T;
int n;
int ans=0;
int DP()
{

    for(int i=0;i<=n+1;i++) dp1[i]=dp2[i]=-99999999;
    ans=-99999999;
    for(int i=1;i<=n;i++)
    {
        a[i]=max(a[i-1]+aa[i],aa[i]);
    }
    for(int i=n;i>=1;i--)
    {
        b[i]=max(b[i+1]+aa[i],aa[i]);
    }
    for(int i=1;i<=n;i++)
    dp1[i]=max(dp1[i-1],a[i]);
    for(int i=n;i>=1;i--)
    dp2[i]=max(dp2[i+1],b[i]);
    for(int i=1;i<=n;i++)
    ans=max(dp1[i]+dp2[i+1],ans);
    return ans;


}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",&aa[i]);
        printf("%d\n",DP());    
    }


}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值