【poj 3321】 Apple Tree 树状数组+dfs序

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23568 Accepted: 7118

Description

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output
For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source
POJ Monthly–2007.08.05, Huang, Jinsong

题目链接:http://poj.org/problem?id=3321

题意
给出一个苹果树,每个节点一开始都有苹果
C X,如果X点有苹果,则拿掉,如果没有,则新长出一个
Q X,查询X点与它的所有后代分支一共有几个苹果

思路:1为根节点,子树问题用dfs序,然后区间查询,单点修改–》树状数组
*注意!!

typedef vector<int> ve_int;
vector<ve_int> lin(100005);
!vector定义   ,不然TLE!

代码

#include<iostream>
#include<vector>
#include<stdio.h>
#include<string.h>
using namespace std;
int in[100005],out[100005];
int C[100005];
int a[100005];
int n,m;
int tot=0;
typedef vector<int> ve_int;//---!!!
vector<ve_int> lin(100005);
void dfs(int x,int fa)
{
    in[x]=++tot;
    int len=lin[x].size();
    for(int i=0;i<len;i++)
    {
        int y=lin[x][i];
        if(y==fa) continue;
        dfs(y,x);
    }
    out[x]=tot;
}
void add(int x,int y)
{
    while(x<=n)
    {
        C[x]+=y;
        x+=x&(-x);
    }
}
int _get(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=C[x];
        x-=x&(-x);
    }
    return ret;
}
int main()
{
    int aa,bb;
    scanf("%d",&n);
    for(int i=1;i<n;i++)
    {
        scanf("%d%d",&aa,&bb);
        lin[aa].push_back(bb);
        lin[bb].push_back(aa);
    }
    dfs(1,0);
    char s[3];
    scanf("%d",&m);
//  for(int i=1;i<=n;i++)
//  cout<<i<<"   "<<in[i]<<" "<<out[i]<<endl;
    for(int i=1;i<=m;i++)
    {
        scanf("%s%d",s,&aa);
        if(s[0]=='Q')
        printf("%d\n",out[aa]-in[aa]+1-(_get(out[aa])-_get(in[aa]-1)));
        else
        {
            if(a[aa]==0)
            {
            add(in[aa],1);
            a[aa]=1;
            }

            else 
            {
            add(in[aa],-1);
            a[aa]=0;
            }
        }
    }

}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值