NSOJ Prime Ring Problem


Prime Ring Problem

时间限制: 2000ms
内存限制: 32768KB
HDU       ID:  1016
64位整型:      Java 类名:
类型: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • 题目描述

    A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

    Note: the number of first circle should always be 1.


    输入

    n (0 < n < 20).

    输出

    The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

    You are to write a program that completes above process.

    Print a blank line after each case.

    样例输入

    6
    8

    样例输出

    Case 1:
    1 4 3 2 5 6
    1 6 5 2 3 4
    
    Case 2:
    1 2 3 8 5 6 7 4
    1 2 5 8 3 4 7 6
    1 4 7 6 5 8 3 2
    1 6 7 4 3 8 5 2

    来源

    思路:这个题是个比较水的搜索题,用深搜,但是需要注意,只有偶数才可以构成圈,不过1比较特殊,1自己就可以构成一个圈。



    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    int a[21],n,flag,prime[41],book[21];
    void dfs(int step)
    {
        if(step==n&&prime[a[step-1]+1])
        {
            printf("1");
            for(int i=1; i<step; i++)
                printf(" %d",a[i]);
            printf("\n");
           return ;
        }
        for(int i=2; i<=n; i++)
        {
            if(!book[i]&&prime[a[step-1]+i])
            {
                book[i]=1;
                a[step]=i;
                dfs(step+1);
                book[i]=0;
            }
        }
    }
    int main()
    {
        int i,j,k;
        for(i=2; i<40; i++)
        {
            k=sqrt(i);
            for(j=2; j<=k; j++)
                if(i%j==0)
                    break;
                    if(j>k)
                        prime[i]=1;
                    else prime[i]=0;
        }
        k=1;
        while(~scanf("%d",&n))
        {
            memset(book,0,sizeof(book));
            if(n==1)
            {
              printf("Case %d:\n",k++);
               printf("1\n");
            }
            else if(n%2)
                continue;
            else { printf("Case %d:\n",k++);
            a[0]=1;
            dfs(1);}
            printf("\n");
        }
        return 0;
    }
    



    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值