POJ 1724 ROADS

                                           

ROADS

 

                                                               

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 
Input
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
Output
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 
Sample Input
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
Sample Output
11

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int book[110];
int n,m,V,sum,flag,min1;

struct note
{
    int city1;
    int city2;
    int len;
    int cose;
} que[10100];
int head[101];

void dfs(int city,int len,int cose)
{
    if(len>=min1||cose>V)
        return ;
    if(city==n)
    {
       if(len<min1)
        min1=len;
        flag=1;
        return ;
    }
    for(int i=head[city]; i; i=que[i].city2)
    {
        if(book[que[i].city1])
            continue;
        book[que[i].city1]=1;
        dfs(que[i].city1,len+que[i].len,cose+que[i].cose);
        book[que[i].city1]=0;
    }
}

int main()
{
    scanf("%d %d %d",&V,&n,&m);
    memset(book,0,sizeof(book));
    memset(head,0,sizeof(head));
    flag=0;
    min1=9999999;
    int a;
    for(int i=1; i<=m; i++)
    {
        scanf("%d %d %d %d",&a,&que[i].city1,&que[i].len,&que[i].cose);
        que[i].city2=head[a];
        head[a]=i;
    }
    book[1]=1;
    dfs(1,0,0);
    if(!flag)
        printf("-1");
    else printf("%d\n",min1);
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值