Dating with girls(2)

Dating with girls(2)

 

 

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down. 

Input

The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10). 
The next r line is the map’s description.

Output

For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".

Sample Input

1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.

Sample Output

7

题意:男孩寻找女孩,途中会遇到门,当时间为K的倍数时,门会消失,判断男孩能否找到女孩;

思路

这样一个路径可能走过一次了 还要再走 因为可能一开始石头在 后来石头不在了,在时间能被k整除的时候障碍会消失,这样就需要在一般的二维迷宫判重数组上加上一维。这一维的意义是总时间模k的余数 这样来表示一种状态book[i][j][t]的意义是总时间模k余t时在x,y。因为一个格子上不同的时间余数代表不同的状态,在这些状态下扩展出的节点可能不同,所以需要三维标记

代码:

​
#include<stdio.h> 
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

int r,c,k;
int ne[4][2]={1,0,0,1,-1,0,0,-1};
int book[110][110][20];//因为要判断时间是否为K的倍数,所以用三维数组来标记 
char map[110][110];
int x1,y1;

struct node
{
	int x,y,step;
};

int bfs(int x,int y)
{
	queue<node>q;
	node st,en;
	st.x=x;
	st.y=y;
	st.step=0;
	book[x][y][st.step%k]=1;
	q.push(st);
	while(!q.empty())
	{
		st=q.front();
		q.pop();
		if(map[st.x][st.y]=='G')
		   return st.step;
		for(int i=0;i<4;i++)
		{
			int tx=st.x+ne[i][0];
			int ty=st.y+ne[i][1];
			en.step=st.step+1;
			if(tx<0||ty<0||tx>=r||ty>=c||book[tx][ty][en.step%k])
			   continue;
			if(map[tx][ty]=='#'&&en.step%k)//当为 #时,判断时间是否为 K的倍数,门是否消失 
			 continue;
			book[tx][ty][en.step%k]=1;
			en.x=tx;
			en.y=ty; 
			q.push(en);   
		}
	}
	return -1;
}
int main()
{
	int n;
    scanf("%d",&n);
	while(n--)
	{
		int i,j;
		scanf("%d%d%d",&r,&c,&k);
		memset(book,0,sizeof(book));
		for(i=0;i<r;i++)
		 scanf("%s",map[i]);
		for(i=0;i<r;i++)
		{
			for(j=0;j<c;j++)
			{
				if(map[i][j]=='Y')//找到男孩的位置 
				{
					x1=i;y1=j;
					break;
				 } 
			}
		}
		int f=bfs(x1,y1);
		if(f==-1)
		 printf("Please give me another chance!\n");
		else
		printf("%d\n",f);
	}
}

​

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值