How far away ? HDU - 2586



How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17281    Accepted Submission(s): 6662


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
      
      
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
      
      
10 25 100 100
 

Source

题意:求最短路。
解题思路:使用两个向量数组,一个存边关系,一个存权值,按照先后顺序,找最短路时,再使用站的先入先出的思想,向四周发散开来,避免成圈,需要进行标记,再用一个数组存,从初始点到每个点的距离。代码很好理解,如果不理解怎样存的权值,可以动手模拟一下,就理解了。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <stack>
using namespace  std;
#define maxn 40000+10

vector<int>V[maxn];
vector<int>W[maxn];

int n,m,vis[maxn],dis[maxn];

void Inf()
{
    for(int i=1; i<=n; i++)
    {
        V[i].clear();
        W[i].clear();
    }
}

int  dfs(int x,int y)
{
    stack<int>Q;
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    Q.push(x);
    vis[x]=1;

    while(!Q.empty())
    {
        int p=Q.top();
        Q.pop();
        if(p==y)
            break;
        for(int i=0; i<V[p].size(); i++)
        {
            int t=V[p][i];
            if(vis[t]) continue;
            vis[t]=1;
            Q.push(t);
            dis[t]=dis[p]+W[p][i];      //W向量,存的权值
        }
    }
    return dis[y];
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        Inf();
        scanf("%d %d",&n,&m);
        int a,b,c;
        for(int i=1; i<n; i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            V[a].push_back(b);       //无向图,双向存储
            V[b].push_back(a);
            W[a].push_back(c);  
            W[b].push_back(c);      //方便,后面的权值向加。
        }
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&a,&b);
            printf("%d\n",dfs(a,b));
        }
    }
    return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值