折半查找之函数 poj2785

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2   28  ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:给出一个n表示有多少行数字,每行有四个,表示分别是A B C D四个集合中各一个,问:从 A B C D四个集合中各拿出一个数字,加起来为0,共有几种情况。

  思路:四个集合,如果写四层循环一定会超时的,只能进行分开查找的,把其中两个集合的每个元素都分别相加,而到一个很大的集合,在枚举剩下的两个集合的和,去很大的集合中进行查找,因为可能会有重复的,所以普通的二分查找,根本不行,这儿需要一个折半的公式得到共有多少个重复的。

AC代码:

#include<iostream>  
#include<cstdio>  
#include<algorithm>  
using namespace std;  
const int maxn=4005;
#define ll long long 
ll sum[maxn*maxn];
ll A[4500],B[4500],C[4500],D[4500];
int n,m;
int main()
{
	while(~scanf("%d",&n))
	{
		m=0;
		for(int i=0;i<n;i++)
		scanf("%lld %lld %lld %lld",&A[i],&B[i],&C[i],&D[i]);
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
			sum[m++]=A[i]+B[j];
		sort(sum,sum+m);
		int cont=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
			   int term=C[i]+D[j];
			   cont+=upper_bound(sum,sum+m,-term)-lower_bound(sum,sum+m,-term);
			}
		}
		printf("%d\n",cont);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值