4 Values Whose Sum is 0(POJ No.2785)

4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 40350 Accepted: 12353
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目大意:

给定各有n个整数的四个数列A、B、C、D.要从每个数列中各选出一个数(分别为a,b,c,d),使四个数的和为0.求出这样组合的个数。当一个数列中由多个相同的数字时,把他们看作不同的数字。

方案一:

直接从四个数列中枚举四个数,时间复杂度为O(n^4),由于数据量为1e3级别,所以会超时

方案二:

题目是求a+b+c+d=0的方案数,可以把问题转换为c+d=-(a+b)的方案数,这样可以在O(n^2)内枚举出数列A和数列B能表示出的所有整数存入vis数组。然后再枚举c和d,再利用二分查找搜数组中大小为-(c+d)的元素的个数。

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 4e3+10;
int vis[maxn*maxn];
int A[maxn],B[maxn],C[maxn],D[maxn];
int main()
{
    int n;
    cin>>n;
    for(int i = 0;i<n;i++)
    {
        cin>>A[i]>>B[i]>>C[i]>>D[i];
    }
    //枚举
    for(int i = 0;i<n;i++)
    {
        for(int j = 0;j<n;j++)
        {
            vis[i*n+j]=A[i]+B[j];
        }
    }
    long long ans = 0;
    
    //因为要二分查找所以要先排序
    sort(vis,vis+n*n);
    //枚举C和D
    for(int i=0;i<n;i++)
    {
        for(int j = 0;j<n;j++)
        {
            int temp = -(C[i]+D[j]);
            int x = upper_bound(vis,vis+n*n,temp)-lower_bound(vis,vis+n*n,temp);
            if(x)
            {
                ans+=x;
            }
        }
    }
    cout<<ans<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值