二分查数位置,时间复杂度分析

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

思路:

做这个题主要的是时间复杂度的分析问题
计算机一秒(1000ms)能执行的大约为1e9
不用脑子的办法四重循环,4000的4次方=6.41e13,必超时
第一列加第二列4000
4000=1.61e6,第三列加第四列40004000=1.61e6
共3.2
1e6,相加之后,要排序,函数sort复杂度nlog2n=4000log2 4000约等于4.81e4,两个就是9.61e4,2/2分时间复杂度9.61e4+3.21e6必不超时,同理可分析3/1分也超时

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int a[4002][4],sum1[16000002],sum2[16000002];
int main()
{
    int n,mid;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d%d",&a[i][0],&a[i][1], &a[i][2],&a[i][3]);
        }
        int k=0;
        int m=0;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                sum1[k++]=a[i][0]+a[j][1];
                sum2[m++]=a[i][2]+a[j][3];
            }
        sort(sum2,sum2+k);
        int cnt=0;
        for(int i=0; i<k; i++)
        {
            int left=0;
            int right=k-1;
            while(left<=right)
            {
                mid=(left+right)/2;
                if(sum1[i]+sum2[mid]==0)
                {
                    cnt++;
                    for(int j=mid+1;j<k;j++)
                    {
                        if(sum1[i]+sum2[j]!=0)
                           break;
                        else
                        cnt++;
                    }
                    for(int j=mid-1;j>=0;j--)
                    {
                        if(sum1[i]+sum2[j]!=0)
                           break;
                        else
                           cnt++;
                    }
                    break;
                }
                if(sum1[i]+sum2[mid]<0)
                    left=mid+1;
                else
                    right=mid-1;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值