Big Number

Big Number
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 54 Accepted Submission(s) : 19
Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10[sup]7[/sup] on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19

#include <stdio.h>
int main()
{
    int n,i=0,j,a;
    double s=1;
    scanf("%d",&n);
    while(n--){
    	scanf("%d",&a);
    	for(j=2;j<=a;j++){
    		s=s*j;
    		while(s>=10){
		    	s=s/10;
			    i++;
		    }
		}
		printf("%d\n",i+1);
		i=0;
		s=1;
	}
    return 0;
}

根据题意,最后的s一定会很大,所以在一边累乘的时候要一边统计位数一边给s缩小十倍就不容易越界,但是这里的s一定要保留小数,因为如果不保留小数的话,算出来的结果会偏小,举个例子,2.54和24的位数就是不一样的,所以后面的小数一定要保留,不然结果会出现错误

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值