poj-2689-大区间求素数(数论)

Prime Distance

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18614 Accepted: 4982

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

Waterloo local 1998.10.17

 

题意:给出起始和结束数字,求出在这两个数字之间(包括这两个数)的相邻最近的和相邻最远的数

 

方法一:

 

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
#define N 1000005
#define M 46500
#define INF 999999999

bool notprime[N];
int prime1[M+1], prime2[N];
int num1 = 0, num2;
void Prime1()//晒出0——M内的数,埃式筛法
{
    memset(notprime,0,sizeof(notprime));
    for(int i=2; i<=M; i++)
    {
        if(!notprime[i])
        {
            prime1[num1++] = i;
            for(int j=2*i; j<=M; j+=i)
                notprime[j] = 1;
        }
    }
}
void Prime2(int l, int u)
{
    memset(notprime,0,sizeof(notprime));
    num2 = 0;
    if(l < 2)//这个很重要
        l = 2;
    int k = sqrt(u*1.0);
    for(int i=0; i<num1 && prime1[i]<=k; i++)//运用sqrt(u)以内的素数来生成
    {
        int t = l/prime1[i];//让t*(prime[i])从l开始到u结束
        if(t*prime1[i] < l)
            t++;
        if(t <= 1)
            t = 2;
        for(int j=t; (long long)j*prime1[i]<=u; j++)
        {
            notprime[j*prime1[i]-l] = 1;
        }
    }
    for(int i=0; i<=u-l; i++)
    {
        if(!notprime[i])
            prime2[num2++] = i+l;
    }
}
int main()
{
    int l, u, dis, a1, b1, a2, b2, minn, maxx;
    Prime1();
    while(cin >> l >> u)
    {
        minn = INF;
        maxx = -1;
        Prime2(l, u);
        if(num2 < 2)
        {
            cout << "There are no adjacent primes." << endl;
            continue;
        }
        for(int i=1; i<num2 && prime2[i]<=u; i++)
        {
            dis = prime2[i]-prime2[i-1];
            if(dis < minn)
            {
                b1 = prime2[i-1];
                b2 = prime2[i];
                minn = dis;
            }
            if(dis > maxx)
            {
                a1 = prime2[i-1];
                a2 = prime2[i];
                maxx = dis;
            }
        }
        cout << b1 << "," << b2 << " are closest, " << a1 << "," << a2 << " are most distant." << endl;
    }
    return 0;
}

方法二:比法一要慢,但是好理解

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
#define N 1000005
#define M 46500
#define INF 999999999

bool notprime[N];
int prime1[M+1], prime2[N], prime[N];
long long num1 = 0, num2, l, u;
void segment(long long a, long long b)//两个一起求
{
    num2 = 0;
    long long i, j;
    if(a < 2)//很重要
        a = 2;
    for(i=0; i*i<=b; i++)   prime1[i] = 1;
    for(i=0; i<=b-a; i++)   prime[i] = 1;
    prime1[0] = prime1[1] = 0;//细节
    for(i=2; i*i<=b; i++)
    {
        if(prime1[i])
        {
            for(j=2*i; j*j<=b; j+=i)
                prime1[j] = 0;
            for(j=max(2LL,(a+i-1)/i)*i; j<=b; j+=i)//2LL是(long long)2
            {
                prime[j-a] = 0;
            }
        }
    }
    for(int i=0; i<=b-a; i++)
    {
        if(prime[i])
        {
            prime2[num2++] = i+a;
        }
    }
}
int main()
{
    long long dis, a1, b1, a2, b2, minn, maxx;
    while(cin >> l >> u)
    {
        minn = INF;
        maxx = -1;
        segment(l, u);
        if(num2 < 2)
        {
            cout << "There are no adjacent primes." << endl;
            continue;
        }
        for(int i=1; i<num2 && prime2[i]<=u; i++)
        {
            dis = prime2[i]-prime2[i-1];
            if(dis < minn)
            {
                b1 = prime2[i-1];
                b2 = prime2[i];
                minn = dis;
            }
            if(dis > maxx)
            {
                a1 = prime2[i-1];
                a2 = prime2[i];
                maxx = dis;
            }
        }
        cout << b1 << "," << b2 << " are closest, " << a1 << "," << a2 << " are most distant." << endl;
    }
    return 0;
}

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值