HDU 2717

今天练了一道BFS的题(算是水题吧...然而中间还是出了几次错才AC...不过经过这题 感觉对BFS认识更深刻了一点 下次继续努力吧)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. 

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute 
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute. 

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4


        
  
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
        

已经是很明显的BFS了 三个方向广搜 关键在于要学会剪枝和状态判断 代码如下
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,k;
const int N = 100000+5;
bool Map[N];  //map记录是否访问过此元素
struct node
{
     int x,time;
};
int check(int x)
{
    if(x>=N||Map[x]==true||x<0)//剪枝 1.控制x不要太大或者太小(一开始就是没有想到这个条件导致RE Map数组越界)2.之前没有访问过该状态
        return 0;
    return 1;
}
int BFS()
{
    queue <node> q;
    node now, next;
    now.x = n , now.time = 0;
    q.push(now);
    while(!q.empty())//三个方向广搜
    {
        now = q.front();//取出队首元素
        q.pop();
        if(now.x == k)//终止条件
        {
            return now.time;//返回需要消耗的时间
        }
        next.x    = now.x + 1;
        next.time = now.time + 1;
        if(check(next.x))
            {
                q.push(next);
                Map[next.x]=1;//记录节点的状态
            }
      //一个方向
        next.x    = now.x - 1;
        next.time = now.time + 1;
        if(check(next.x))
            {
                q.push(next);
                Map[next.x]=1;
            }
        //另一个方向
        next.x    = now.x * 2;
        next.time = now.time + 1;
       if(check(next.x))
            {
                q.push(next);
                Map[next.x]=1;
            }
        //最后一个方向
    }
    return -1;
}
int main()
{
    int ans;
    while(~scanf("%d%d",&n,&k))
    {
        memset(Map,0,sizeof(Map));;
        ans=BFS();
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值