算法与数据结构之STL和基本数据结构 栈stack、队列queue、链表和list、set

栈stack

栈的特点是先进后出,形象的讲就是往一个单口圆形的杯子里加入半径与杯口相同。显然,这样放球最后放的最先拿出来,最先放的最后才能拿出来。 栈的概念在Java中非常重要。
头文件: #include < stack >

相关操作
代码示例说明
stack < Type > s;定义一个栈,数据类型为Type,实例化为int,double,string等
s.push(item);把item放到栈顶
s.top();返回栈顶的元素
s.pop()删除栈顶的元素,无返回值。需要先top()栈顶值
s.size()返回栈顶的元素
s.empty();检查栈是否为空
题目示例

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

简单的讲就是翻转字符串。

#include <iostream>
#include <vector>
#include <stack>
using namespace std; 
int main() {
	int n;
	char ch;
	scanf("%d",&n);
	getchar();
	while(n--){
		stack <char> s;
		while(true){
			ch = getchar();
			if(ch == ' ' || ch == '\n' || ch == EOF){
				while(!s.empty()){
					printf("%c",s.top());
					s.pop();
				}
				if(ch == '\n' || ch ==EOF) break;
				printf(" ");
			}
			else{
				s.push(ch);
			}
		}
		printf("\n");
	}
	return 0;
}

队列queue

队列的特点是先进先出,好比排队,水管。
头文件: #include < queue >
常用操作:

代码示例说明
queue < Type > q ;定义一个队列,Type为数据类型,int,float,double
q.push(item);把item放入队列
q.front();返回队首元素,返回的只是元素,不会对队首进行其他操作
q.pop();删除队首元素
q.back();返回队尾元素
q.size();返回元素个数
q.empty();检查队列是否为空
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值