KMP(2)--hdu2594

Simpsons’ Hidden Talents



                                              Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3


     这题的题意是求s1的前缀和s2的后缀重复度的最大值:输入 s1 s2 问s2的后缀 以及s1的前缀中 相同的字符最多有多少个 是什么

    水题,就是将s2作为文本串,s1某个前缀作为模式串,问在s2中能匹配到s1的最大前缀,但是注意它问的是s2的后缀,所以在s2中找到的s1的某个前缀如果不是在s2串的末尾,就继续找,直到找到的s1的某个前缀是在s2的最末尾。

应该说清楚了吧......

#include<stdio.h>
#include<string.h>
#define MAX 50005
int next[MAX];
char str1[MAX],str2[MAX];
void GetNextval(){
	int plen=strlen(str1);
	int i=0;
	int j=next[0]=-1;
	while(i<plen){
		if(j==-1||str1[i]==str1[j]){
			next[++i]=++j;
		}
		else j=next[j];
	}
}
int KMP(){
	int len=strlen(str2);
	int plen=strlen(str1);
	int i=0;
	int j=0;
	while(i<len){
		if(j==plen){
			j=next[j];
		}
		if(j==-1||str2[i]==str1[j]){
			i++;
			j++;
		}
		else j=next[j];
	}
	return j;      //返回找到的s1前缀的最末尾的字符的下标
}
int main()
{
	while(scanf("%s%s",str1,str2)!=EOF){
		GetNextval();
		str1[KMP()]='\0';
		if(KMP())printf("%s %d\n",str1,KMP());
		else printf("0\n");
	}
	return 0;
}
			s[i+len]=s[i];
		}
		s[i+len]='\0';
		GetNextval();
		if(KMP())printf("yes\n");    //根据下标输出找到的最长的s1的前缀
		else printf("no\n");
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
校园悬赏任务平台对字典管理、论坛管理、任务资讯任务资讯公告管理、接取用户管理、任务管理、任务咨询管理、任务收藏管理、任务评价管理、任务订单管理、发布用户管理、管理员管理等进行集中化处理。经过前面自己查阅的网络知识,加上自己在学校课堂上学习的知识,决定开发系统选择小程序模式这种高效率的模式完成系统功能开发。这种模式让操作员基于浏览器的方式进行网站访问,采用的主流的Java语言这种面向对象的语言进行校园悬赏任务平台程序的开发,在数据库的选择上面,选择功能强大的Mysql数据库进行数据的存放操作。校园悬赏任务平台的开发让用户查看任务信息变得容易,让管理员高效管理任务信息。 校园悬赏任务平台具有管理员角色,用户角色,这几个操作权限。 校园悬赏任务平台针对管理员设置的功能有:添加并管理各种类型信息,管理用户账户信息,管理任务信息,管理任务资讯公告信息等内容。 校园悬赏任务平台针对用户设置的功能有:查看并修改个人信息,查看任务信息,查看任务资讯公告信息等内容。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。项目管理页面提供的功能操作有:查看任务,删除任务操作,新增任务操作,修改任务操作。任务资讯公告信息管理页面提供的功能操作有:新增任务资讯公告,修改任务资讯公告,删除任务资讯公告操作。任务资讯公告类型管理页面显示所有任务资讯公告类型,在此页面既可以让管理员添加新的任务资讯公告信息类型,也能对已有的任务资讯公告类型信息执行编辑更新,失效的任务资讯公告类型信息也能让管理员快速删除。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值