模拟(1)--poj3087(简单模拟)

      Shuffle'm Up

Time Limit: 1000MS     Memory Limit: 65536KB     64bit IO Format: %lld & %llu

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips,S1 andS2, each stack containingC chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below forC = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip fromS2. On top of that chip, is the bottommost chip fromS1. The interleaving process continues taking the 2nd chip from the bottom ofS2 and placing that onS12, followed by the 2nd chip from the bottom ofS1 and so on until the topmost chip fromS1 is placed on top ofS12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommostC chips fromS12 to form a newS1 and the topmostC chips fromS12 to form a newS2. The shuffle operation may then be repeated to form a newS12.

For this problem, you will write a program to determine if a particular resultant stackS12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integerC, (1 ≤C ≤ 100) which is the number of chips in each initial stack (S1 andS2). The second line of each dataset specifies the colors of each of theC chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of theC chips in stackS2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A throughH). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 *C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 thoughN), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1


        题目大意是:给两堆牌S1和S2(ABC和BCA),两堆牌各有C张,注意给的每一堆牌的顺序是从下到上,先拿S2这一堆的最底下的那张牌即B,再拿S1的最底下A,以此类推,得到S12(BACBAC),这个S12的顺序也是从下到上的顺序,然后最底下C张变成原来的S1,最顶上C张变成S2,重复操作,判断到某一个S12 状态需要操作的次数,若永远不可能相同,则输出"-1"。

        这道题就是纯模拟,我运用了队列和map来实现,map主要是判重,建一个map容器,装目前为止已经出现的所有情况,一旦出现map容器中出此案过的情况,意外着出现了循环,就永远到达不了目标状态,即输出-1。AC代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <queue>
#include <map>
using namespace std;
int n;
int Judge(char str1[],char str2[],char str[]){      //模拟洗牌的过程
	char s[205];
	memset(s,0,sizeof(s));
	int i;
	map<string,int>m;        //用c++中的map(STL容器)表示已经出现的所有情况的集合
	queue<char>q1;
	queue<char>q2;
	for(i=0;i<strlen(str1);i++){
		q1.push(str1[i]);
	}
	for(i=0;i<strlen(str2);i++){
		q2.push(str2[i]);
	}
	strcat(s,str1);
	strcat(s,str2);
	m[s]=0;
	int ans=0;
	if(strcmp(s,str)==0)return ans;
	while(1){
		i=0;
		ans++;
		while(i<2*n){             //模拟洗牌
			s[i]=q2.front();
			q2.pop();
			s[i+1]=q1.front();
			q1.pop();
			i+=2;
		}
		s[2*n]='\0';
		if(strcmp(s,str)==0)return ans;    //已搜到,输出搜索次数
		if(!m[s])m[s]++;      
		else return -1;       //若此情况已经在map容器中出现过了,则说明搜索失败
		for(i=0;i<n;i++){
			q1.push(s[i]);
		}
		for(i=n;i<2*n;i++){
			q2.push(s[i]);
		}
	}
}
int main()
{
	int T,cnt=0;
	char str1[105],str2[105],str[205];
	scanf("%d",&T);
	while(T--){
		cnt++;
		scanf("%d",&n);
		scanf("%s %s %s",str1,str2,str);
		printf("%d %d\n",cnt,Judge(str1,str2,str));
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值