最短路径(8)--poj3660(用floyd求传递闭包)

Cow Contest

                                         Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu


Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cowA has a greater skill level than cow B (1 ≤ AN; 1 ≤BN; AB), then cow A will always beat cowB.

Farmer John is trying to rank the cows by skill level. Given a list the results ofM (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer,A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

           

           这道题题目大意:有N头牛,评以N个等级,各不相同,先给出部分牛的等级的高低关系,问最多能确定多少头牛的等级。


解题思路:一头牛的等级,当且仅当它与其它N-1头牛的关系确定时确定,于是我们可以将牛的等级关系看做一张有向图,然后进行适当的松弛操作,得到任意两点的关系,再对每一头牛进行检查即可。即利
用floyd求传递闭包。

代码:

#include <stdio.h>
#include <string.h>
#define MAX 105
int map[MAX][MAX];
int n,m;
void Floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
	{
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(!map[i][j])map[i][j]=(map[i][k]&&map[k][j]);
			}
		}
	}
}
int main()
{
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(map,0,sizeof(map));
		for(i=0;i<m;i++)
		{
			int a,b;
			scanf("%d %d",&a,&b);
			map[a][b]=1;             //a与b的关系确定  标记为1
		}
		Floyd();
		int ans=0;  
        for(int i=1;i<=n;i++)  
        {  
            int sum=0;  
            for(int j=1;j<=n;j++)  
                if(map[i][j]||map[j][i])sum++;  
				if(sum==n-1)              //如果一头牛和其他所有牛的关系确定了的话,它的排名也就确定了。  
					ans++;
        }
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值