1124 平面中的点 point类Ⅳ

话不多说,先上题目为敬~!

Problem D: 平面上的点——Point类 (IV)

Time Limit: 1 Sec   Memory Limit: 4 MB
Submit: 5400   Solved: 3167
[ Submit][ Status][ Web Board]

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定。现在我们封装一个“Point类”来实现平面上的点的操作。

根据“append.cc”,完成Point类的构造方法和show()、showCounter()、showSumOfPoint()方法;实现showPoint()函数。

接口描述:
showPoint()函数:按输出格式输出Point对象,调用Point::show()方法实现。
Point::show()方法:按输出格式输出Point对象。
Point::showCounter()方法:按格式输出当前程序中Point对象的计数。
Point::showSumOfPoint()方法:按格式输出程序运行至当前存在过的Point对象总数。

Input

输入多行,每行为一组坐标“x,y”,表示点的x坐标和y坐标,x和y的值都在double数据范围内。

Output

对每个Point对象,调用show()方法输出其值,或者用showPoint()函数来输出(通过参数传入的)Point对象的值:X坐标在前,Y坐标在后,Y坐标前面多输出一个空格。每个坐标的输出精度为最长16位。调用用showCounter()方法和showSumOfPoint()输出Point对象的计数统计,输出格式见sample。

C语言的输入输出被禁用。

Sample Input

1,23,32,1

Sample Output

Point : (1, 2)Current : 2 points.Point : (3, 3)Current : 2 points.Point : (2, 1)Current : 2 points.In total : 4 points.Current : 3 points.Point : (0, 0)Point : (1, 1)Point : (0, 0)In total : 6 points.

HINT

对象计数通过静态成员来实现

Append Code

append cc中的内容为
int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        p.show();
        p.showCounter();
    }
    q.showSumOfPoint();
    Point q1(q), q2(1);
    Point::showCounter();
    showPoint(q1, q2, q);
    Point::showSumOfPoint();
}
这个题目在point类Ⅲ的基础上增加了静态成员的考察。静态成员是所有类共用的成员,在所有类中的数值是一样的。需要记住的是静态成员的写法。在private中定义,并且在类外进行初始化。切记一定要进行初始化。并且private中的静态成员只能由public中的静态函数来访问,其他成员函数无权访问。、
话不多少,代码奉上~~
要注意消除析构函数的额外调用。如果不消除这一点的话在计数上会存在错误。
#include <iostream>
using namespace std;
#include <iomanip>
class Point{
private:
    double x,y;
    static int sta1;
    static int sta2;
public:
    Point(double a,double b)
    {
        x = a;
        y = b;
        sta1++;
        sta2++;

    }
    Point(int f)
    {
        x = f;
        y = f;
        sta1++;
        sta2++;

    }
    Point()
    {
        x = 0;
        y = 0;
        sta1++;
        sta2++;

    }
    Point(const Point &p)
    {
         x = p.x;
         y = p.y;
         sta1++;
         sta2++;

    }
    void show()
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")"<<endl;
    }
    ~Point()
    {
        sta1--;
    }
    static void showCounter()
    {
        cout<<"Current : "<<sta1<<" points."<<endl;
    }
    static void showSumOfPoint()
    {
        cout<<"In total : "<<sta2<<" points."<<endl;
    }

};
    int Point::sta1(0);
    int Point::sta2(0);
    void showPoint(Point p)
    {
        p.show();
    }
    void showPoint(Point &p1,Point &p2,Point &p3)
    {
        p1.show();
        p2.show();
        p3.show();
    }



int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        p.show();
        p.showCounter();
    }
    q.showSumOfPoint();
    Point q1(q), q2(1);
    Point::showCounter();
    showPoint(q1, q2, q);
    Point::showSumOfPoint();
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值