Problem : 平面上的点和线——Point类、Line类 (II)

话不多说,先上题目为敬~

Problem B: 平面上的点和线——Point类、Line类 (II)

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 3459   Solved: 2364
[ Submit][ Status][ Web Board]

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象的构造和析构次序。
接口描述:
Point::show()方法:按格式输出Point对象。
Line::show()方法:按格式输出Line对象。

Input

输入的第一行为N,表示后面有N行测试样例。每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

Point : (0, 0)Line : (0, 0) to (1, 1) is created.Line : (0, 0) to (1, 1)Line : (0, 0) to (1, 1) is erased.Line : (1, 1) to (2, 3) is created.Line : (1, 1) to (2, 3)Line : (1, 1) to (2, 3) is erased.Line : (2, 3) to (4, 5) is created.Line : (2, 3) to (4, 5)Line : (2, 3) to (4, 5) is erased.Line : (0, 1) to (1, 0) is created.Line : (0, 1) to (1, 0)Line : (0, 1) to (1, 0) is erased.Line : (1, -2) to (2, -1) is created.Line : (1, -2) to (0, 0) is created.Line : (2, -1) to (0, 0) is created.Line : (0, 0) to (2, -1) is created.Line : (1, -2) to (2, -1)Line : (1, -2) to (0, 0)Line : (2, -1) to (0, 0)Line : (0, 0) to (2, -1)Line : (0, 0) to (2, -1) is erased.Line : (2, -1) to (0, 0) is erased.Line : (1, -2) to (0, 0) is erased.Line : (1, -2) to (2, -1) is erased.

HINT

Append Code

append.cc中的内容为
int main()
{
    char c;
    int num, i;
    double x1, x2, y1, y2;
    Point p(1, -2), q(2, -1), t;
    t.show();
    std::cin>>num;
    for(i = 1; i <= num; i++)
    {
        std::cin>>x1>>c>>y1>>x2>>c>>y2;
        Line line(x1, y1, x2, y2);
        line.show();
    }
    Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);
    l1.show();
    l2.show();
    l3.show();
    l4.show();
}
是不是在检查输出的时候快要盯瞎了~?哈哈我当时也是这种状况。题目并不难~~答案如下~
#include <iostream>
using namespace std;
class Point{
private:
    double x_,y_;
    friend class Line;
public:
    Point(double x,double y)
    {
        x_ = x;
        y_ = y;
    }
    Point()
    {
        x_ = 0;
        y_ = 0;
    }
    void setvalue(double xx,double yy)
    {
        x_ = xx;
        y_ = yy;
    }
    void setx(int xx) {x_ = xx;}
    void sety(int yy) {y_ = yy;}
    void show()
    {
        cout<<"Point : ("<<x_<<", "<<y_<<")"<<endl;
    }
    int x() { return x_;}
    int y() { return y_;}
 
};
 
class Line{
private:
    Point x1_,y1_;
    double x1,y1,x2,y2;
    friend class Point;
public:
    Line(double xx1,double yy1,double xx2,double yy2)
    {
        x1 = xx1;
        y1 = yy1;
        x2 = xx2;
        y2 = yy2;
        cout<<"Line : ("<<x1<<", "<<y1<<") to ("<<x2<<", "<<y2<<") is created."<<endl;
    }
    Line(Point q1,Point q2)
    {
        x1 = q1.x_;
        y1 = q1.y_;
        x2 = q2.x_;
        y2 = q2.y_;
        cout<<"Line : ("<<x1<<", "<<y1<<") to ("<<x2<<", "<<y2<<") is created."<<endl;
    }
    void show()
    {
        cout<<"Line : ("<<x1<<", "<<y1<<") to ("<<x2<<", "<<y2<<")"<<endl;
    }
    ~Line()
    {
        cout<<"Line : ("<<x1<<", "<<y1<<") to ("<<x2<<", "<<y2<<") is erased."<<endl;
    }
};
 
 
int main()
{
    char c;
    int num, i;
    double x1, x2, y1, y2;
    Point p(1, -2), q(2, -1), t;
    t.show();
    std::cin>>num;
    for(i = 1; i <= num; i++)
    {
        std::cin>>x1>>c>>y1>>x2>>c>>y2;
        Line line(x1, y1, x2, y2);
        line.show();
    }
    Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);
    l1.show();
    l2.show();
    l3.show();
    l4.show();
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值