1001 A+B Format (20)


1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991
作者: CHEN, Yue
单位: PAT联盟
时间限制: 400ms
内存限制: 64MB
代码长度限制: 16KB

#include<iostream>
#include<string>
using namespace std;

int main(){
	int A,B,Sum=0;
	string C;
	cin>>A>>B;
	Sum=A+B;
	if(Sum<0) {
		cout<<"-";
		Sum=-Sum;
	}
	C=to_string(Sum);
	int len=C.length();
	if(len<4)
		cout<<C;
	else{
		for(int i=0;i<len;i++){
			if((len-i-1)%3==0&&(len-i-1)>0)
				cout<<C[i]<<",";
			else cout<<C[i];
		}
	}
	cout<<endl;
	return 0;
}
先将负数转换成正数,然后判断(len-i-1)%3==0是否成立(由于最后一个位置不输出‘,’,所以还要使len-i-1>0)成立则输出‘,’。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值