POJ-3641:Pseudoprime numbers

题目:

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output
 

no no yes no yes yes


概译:费马定理觉得所有的素数p都是,给定一个大于1小于p的a, a的p次幂模p的值为a。然后有一些不是素数的p对于某些a也有同样的性质,我们就叫他基于a 的Pseudoprime(a从1到p都成立的就叫Carmichael number啦,别的题里大家应该见过)。现在给一些组p和a,判断一下是不是Pseudoprime number。

题目很水,只是借机留下几个基础的模板。详见代码:

#include<iostream>
#include<cstdio>
#include<cmath>

using namespace std;

bool isprime(int n)//试除法判定素数 
{
	int m=floor(sqrt(n)+0.5);
	//这里sqrt应该都懂……+0.5是避免浮点数误差,因为下面枚举时举i<=m的,所以不要紧 
	//如果不用变量m而是直接把sqrt写循环里,那会导致每次都计算一遍sqrt,会增加时间 
	for(int i=2;i<=m;i++)
		if(n%i==0)
			return false;
	return n>1;//最后滤去0和1 
}
int qmul(int a,int b,int mod)//快速乘,类似于快速幂 
{
	int ans=0;
	while(b)
	{
		if(b&1)
			ans=(ans+a)%mod;
		b>>=1;
		a=a*2%mod;
	}
	return ans;
}
int qpow(int a,int n,int mod)//快速幂,自己在纸上随便列两个数写一遍就懂了 
{
	int res=1;
	while(n)
	{
		if(n&1)
			res=qmul(res,a,mod)%mod;//原型为res=res*a%mod,这里没用longlong怕爆 
		n>>=1;
		a=qmul(a,a,mod)%mod;//原型为a=a*a%mod 
	}
	return res;
}
int main()
{
	int p,a;
	
	while(~scanf("%d%d",&p,&a)&&p|a)
		printf("%s\n",a==qpow(a,p,p)&&!isprime(p)?"yes":"no");

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值