1080. Graduate Admission (30)

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4
想到的方法是用multimap,没有直接去算排名,而是直接用成绩map到学生编号,想法是很好的,结果却因为用这个导致了一些问题,解决起来比较麻烦,没有AC。图书馆要闭馆了,今天一天也累了,暂时把这个问题放下,重在思路,日后再想想其他的方法吧,嘿嘿
#include<iostream>
#include<vector>
#include<map>
using namespace std;

struct Student
{
	int ID;
	int Ge;
	int Gi;
	vector<int>vecChoice;
	Student(){ ID = 0; Ge = 0; Gi = 0; vecChoice.clear(); }
}*student;

int main()
{
	int numStu, numSch, choice,quo,sch;
	multimap<int, int> scoreToID;//分数到学生ID的映射
	multimap<int, int>schToStu;//学校录取结果,学校到录取学生的映射
	scanf("%d%d%d", &numStu, &numSch, &choice);
	int *quota = new int[numSch];
	student = new Student[numStu];
	bool *visited = new bool[numSch];
	for (int i = 0; i < numSch; ++i)
	{
		scanf("%d",&quo);
		quota[i] = quo;
		visited[i] = false;
	}

	for (int i = 0; i < numStu; ++i)
	{
		student[i].ID = i;
		scanf("%d%d",&student[i].Ge,&student[i].Gi);
		//scoreToID.insert(make_pair((student[i].Ge + student[i].Gi) / 2, student[i].ID));
		scoreToID.insert(make_pair((student[i].Ge + student[i].Gi) / (-2), student[i].ID));
		for (int j = 0; j < choice; ++j)
		{
			scanf("%d",&sch);
			student[i].vecChoice.push_back(sch);
		}
	}

	//multimap<int, int>::reverse_iterator riter;
	//for (riter = scoreToID.rbegin(); riter != scoreToID.rend(); ++riter)
	multimap<int, int>::iterator riter;
	for (riter = scoreToID.begin(); riter != scoreToID.end(); ++riter)
	{
		for (int i = 0; i < student[riter->second].vecChoice.size(); ++i)
		{
			//判断选择的学校是否招满
			if (schToStu.count(student[riter->second].vecChoice[i]) < quota[student[riter->second].vecChoice[i]])
			{
				//multimap<int, int>::iterator titer = scoreToID.find(riter->first);
				schToStu.insert(make_pair(student[riter->second].vecChoice[i],riter->second));
				break;
			}
			//处理排名相同但是录取名额已满的情况
			else
			{
				multimap<int, int>::iterator fiter = schToStu.find(student[riter->second].vecChoice[i]);
			
				for (int j = 0; j < schToStu.count(student[riter->second].vecChoice[i]); ++j, ++fiter)
				{
					//判断当前处理学生与已录取的学生是否排名相同,总分相同并且GE相同
					if (((student[fiter->second].Ge + student[fiter->second].Gi) == (student[riter->second].Ge +
						student[riter->second].Gi)) && (student[fiter->second].Ge == student[fiter->second].Ge))
					{
						schToStu.insert(make_pair(student[riter->second].vecChoice[i], riter->second));
						break;
					}
				}
			}
		}
	}

	multimap<int, int>::iterator ptiter;
	int count = 0;
	for (ptiter = schToStu.begin(); ptiter != schToStu.end(); ++ptiter)
	{
		while (count < ptiter->first)
		{
			cout << endl;
			++count;
		}
		if (visited[ptiter->first])
			continue;
		visited[ptiter->first] = true;
		multimap<int, int>::iterator titer = schToStu.find(ptiter->first);
		if (schToStu.count(ptiter->first) == 0)
			cout << endl;
		for (int i = 0; i < schToStu.count(ptiter->first); ++i)
		{
			cout << titer->second << " ";
			++titer;
		}
		cout << endl;
		++count;
	}
	while (count < numSch)
	{
		cout << endl;
		++count;
	}
	return 0;
}

结果(大体是对的,还有些问题):

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
select * from ( SELECT P.PATIENT_ID, P.VISIT_ID, PM.NAME, PM.SEX, P.ADMISSION_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_ADMISSION_TO ) AS DEPT_ADM, P.DISCHARGE_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_DISCHARGE_FROM ) AS DEPT_DIS, DATEDIFF( DAY, P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) AS INPAT_DAYS, P.DOCTOR_IN_CHARGE --datediff(day, P.ADMISSION_DATE_TIME,P.DISCHARGE_DATE_TIME) as zyts FROM PAT_VISIT P INNER JOIN PAT_MASTER_INDEX PM ON PM.PATIENT_ID = P.PATIENT_ID WHERE select * from ( SELECT P.PATIENT_ID, P.VISIT_ID, PM.NAME, PM.SEX, P.ADMISSION_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_ADMISSION_TO ) AS DEPT_ADM, P.DISCHARGE_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_DISCHARGE_FROM ) AS DEPT_DIS, DATEDIFF( DAY, P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) AS INPAT_DAYS, P.DOCTOR_IN_CHARGE --datediff(day, P.ADMISSION_DATE_TIME,P.DISCHARGE_DATE_TIME) as zyts FROM PAT_VISIT P INNER JOIN PAT_MASTER_INDEX PM ON PM.PATIENT_ID = P.PATIENT_ID WHERE P.DISCHARGE_DATE_TIME >= '2016-01-01' AND P.DISCHARGE_DATE_TIME < = '2023-07-10' AND DATEDIFF( DAY,P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) >= 30 ) t order by inpat_days desc P.DISCHARGE_DATE_TIME >= '2016-01-01' AND P.DISCHARGE_DATE_TIME < = '2023-07-10' AND DATEDIFF( DAY,P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) >= 30 ) t order by inpat_days desc 帮我把这段sql优化一下
最新发布
07-25

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值