1013 数素数 (20 分)
令 Pi 表示第 i 个素数。现任给两个正整数 M≤N≤104,请输出 PM 到 PN 的所有素数。
输入格式:
输入在一行中给出 M 和 N,其间以空格分隔。
输出格式:
输出从 PM 到 PN 的所有素数,每 10 个数字占 1 行,其间以空格分隔,但行末不得有多余空格。
输入样例:
5 27
输出样例:
11 13 17 19 23 29 31 37 41 43
47 53 59 61 67 71 73 79 83 89
97
#include<stdio.h>
#include<math.h>
int main(){
int m,n;
int i,j,temp=0,count=1;//temp是已打印的数字个数,count是已知的素数个数
int su=-1;
scanf("%d %d",&m,&n);
if(n==1)
{
printf("2");
temp++;
}
if(m==1 && 1!=n)
{
printf("2 ");
temp++;
}
for(i=3;temp<=(n-m+1)&&count<=n;i++)
{
for(j=2;j<=sqrt(i)&&su;j++)
{
if(i%j==0)
{
su=0;
break;
}
}
if(su)
{
count++;
if(count>=m&&count<n)
{
printf("%d",i);
temp++;
if(temp%10==0)
printf("\n");
else
printf(" ");
}
if(count==n)
{
printf("%d",i);
temp++;
}
}
su=-1;
}
return 0;
}