Maximum Sum

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle.

A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

                                                                                0    −2     −7     0

                                                                                9      2     −6      2

                                                                               −4     1     −4      1

                                                                               −1      8      0    −2

is in the lower-left-hand corner:

                                                                               9        2

                                                                              −4       1

                                                                              −1       8

and has the sum of 15.

Input

The input consists of an N × N array of integers.

The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127].

Output

The output is the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2

Sample Output

15

题意:n代表行和列,给了一个n*n的矩阵,求最大的子矩阵的和。

思路:这个题跟上周的最大连续子序列很有关联。我们算出每一列的上边到下边的和,这个和是高度。把矩阵中每一列的数之和转换一个连续的序列。然后我们只需要在这些每一列的和中,选择最大的连续的子序列即可(此时选择是子矩阵的宽度),这样我们就得到了最大的子矩阵的和。代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[110][110];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int maxx=-0xfffffff;
        for(int i=1;i<=n;i++)  //计算每一列的和
        {
            for(int j=1;j<=n;j++)
            {
                int x;
                scanf("%d",&x);
                map[i][j]=map[i-1][j]+x;  
            }
        }
        for(int i=1;i<=n;i++)   //枚举上下边的位置
        {
            for(int j=1;j<=n;j++)  
            {
                if(i<=j)   //下边>=上边
                {
                    int dp[110]={0};   //dp求最大和
                    for(int k=1;k<=n;k++)     
                    {
                        int a=map[j][k]-map[i-1][k];
                        dp[k]=max(dp[k-1]+a,a);
                        if(dp[k]>maxx)   //更新最大值
                            maxx=dp[k];
                    }
                }
            }
        }
        printf("%d\n",maxx);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值