Cheapest Palindrome

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:第一行两个数字 n,m,表示字符串由n种字母组成,m表示字符串长度,然后下面一行给出这个字符串进下来n行每行有两个数字表示 加上这个字符和删去这个字符的花费,求把这个字符串变为回文字符串的最小花费。

思路:这个题主要是构成一个回文字符串,其实在构成回文字符串的过程中,添加还是删除效果是一样的,所以就当成删除并且取删除或tian添加的较小值,然后for循环构造回文串,数组dp[i][j],表示i和j之间构成回文串的最小花费,状态转移方程为:

  dp[j][k]=min(dp[j][k],dp[j+1][k]+a[s[j]-'a']); //如果把左端的进行处理,取处理完左端点的花费
   dp[j][k]=min(dp[j][k],dp[j][k-1]+a【s[k]-'a']);//相当于比较一下是对左端点处理花费少还是右端点花费少

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
char s[2010];             //ans[]存这个字符的费用
int a[30],dp[2010][2010];//dp[i][j]表示从[i,j]之间要构成回文串的最小费用
int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        char c;
        int x,y;
        scanf("%s",s);
        memset(a,0,sizeof(a));
        for(int i=0; i<m; i++)
        {
            getchar();
            scanf("%c %d%d",&c,&x,&y);
            a[c-'a']=min(x,y);//删除还是添加都无所谓,只取最小的费用
        }
        for(int i=1; i<n; i++)
        {
            for(int j=0,k=i; k<n; j++,k++) //算区间
            {
                dp[j][k]=inf;
                if(s[j]==s[k]) //这个区间的两端相等,因此两端对总费用没影响,因此去掉首尾
                    dp[j][k]=dp[j+1][k-1];
                else
                {
                    dp[j][k]=min(dp[j][k],dp[j+1][k]+a[s[j]-'a']); //处理左端点的花费
                    dp[j][k]=min(dp[j][k],dp[j][k-1]+a[s[k]-'a']);//处理右端点的花费,两者取小的
                }
            }
        }
        printf("%d\n",dp[0][n-1]);  // 0到n-
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值