Cheapest Palindrome(dp)

Cheapest Palindrome(dp)

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).

FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input
Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint
If we insert an “a” on the end to get “abcba”, the cost would be 1000. If we delete the “a” on the beginning to get “bcb”, the cost would be 1100. If we insert “bcb” at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意: 给你一个字符串和字符串中各字母删除,增加的代价,让你求使该字符串变成回文串所需要的最小代价

思路: 从局部最优推出全局最优,先从两个字符的开始推,例如bc,把他变成回文有四种方法:bcb(+b),cbc(+c),b(-c),c(-b),但也可简化成两种,我们求出+b,-b那个花费小,以后就只用那个,同c,假设+b,-c的花费相对较小,那我们就再比较+b,+c那个花费小,那如何表示呢,我们先定义dp[i][j]为从i到j区间变成回文的最小代价,那状态转移方程就为dp[i][j]=min(dp[i+1][j]+字符i的较小代价,dp[i][j-1]+字符j的较小代价’]),这个例子,假设+c和-b是较小代价,那我们就前一个状态一定是回文,在这个例如中,前者表示回文c+b,后者表示回文b+c,,若bb,已经是回文了,花费就等价于前一个区间的花费dp[i+1][j-1],可以尝试推到一下,能更好的理解这个过程

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[4100][4100];
char a[2100];
int ad,de,s[4100];
char z;
int main()
{
	int n,m,i,j,k;
	scanf("%d%d",&n,&m);
	scanf("%s",a+1);
	for(i=0;i<n;i++)
	{
		getchar();
		scanf("%c%d%d",&z,&ad,&de);
	//	printf("%c %d %d",z,ad,de);
		s[z-'0']=min(ad,de);//较小代价
	}
	for(i=m-1;i>0;i--)
	{
		for(j=i+1;j<=m;j++)
		{
			if(a[i]==a[j])
			dp[i][j]=dp[i+1][j-1];
			else
			dp[i][j]=min(dp[i+1][j]+s[a[i]-'0'],dp[i][j-1]+s[a[j]-'0']);
		//	printf("%d+++\n",s[a[i]-'0']);
		//	printf("%c--\n",a[i]);
		}
	}
	printf("%d\n",dp[1][m]);
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值