An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
此题的大意是:一共有n台电脑,全部无法链接,O代表修复电脑,S是询问后面输入的两个数据是否能够连接在一起,其中最大的连接距离是d,下面的n行是电脑的坐标;问当遇见S时那两台电脑是否能够连接;
附上代码
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
#define ll long long
int n,d;
int a[100005];
int dis[100005];
struct node{
int x,y;
}p[100005];
int findd(int x)
{
if(a[x]==x)
return x;
else
return a[x]=findd(a[x]);
}
void cover(int xx,int yy)
{
int pp,qq;
pp=findd(xx);
qq=findd(yy);
if(pp!=qq)
a[qq]=pp;
return ;
}
int main()
{
int i,j;
char ch[1000];
int aa,b,c;
while(scanf("%d %d",&n,&d)!=EOF)
{
memset(dis,0,sizeof(dis));//此数组代表所有的电脑还没有修复
for(i=1;i<=n;i++)
{
scanf("%d %d",&p[i].x,&p[i].y);
a[i]=i;
}
while(~scanf("%s",ch))
{
if(ch[0]=='O')
{
scanf("%d",&aa);
if(dis[aa])
continue;
dis[aa]=1;//代表已经修复
for(i=1;i<=n;i++)//遍历一遍看看那些已经修复的能不能连接上
{
if(dis[i]&&i!=aa&&(p[aa].x-p[i].x)*(p[aa].x-p[i].x)+(p[aa].y-p[i].y)*(p[aa].y-p[i].y)<=d*d)
cover(aa,i);
}
}
if(ch[0]=='S')
{
scanf("%d %d",&b,&c);
if(findd(b)==findd(c))
printf("SUCCESS\n");
else
printf("FAIL\n");
}
}
}
return 0;
}