There are N towns on a plane. The i-th town is located at the coordinates (xi,yi). There may be more than one town at the same coordinates.
You can build a road between two towns at coordinates (a,b) and (c,d) for a cost of min(|a−c|,|b−d|) yen (the currency of Japan). It is not possible to build other types of roads.
Your objective is to build roads so that it will be possible to travel between every pair of towns by traversing roads. At least how much money is necessary to achieve this?
Constraints
2≤N≤105
0≤xi,yi≤109
All input values are integers.
输入
Input is given from Standard Input in the following format:
N
x1 y1
x2 y2
:
xN yN
输出
Print the minimum necessary amount of money in order to build roads so that it will be possible to travel between every pair of towns by traversing roads.
样例输入
3 1 5 3 9 7 8
样例输出
3
提示
Build a road between Towns 1 and 2, and another between Towns 2 and 3. The total cost is 2+1=3 yen.
题目大意:给你n个城市的坐标x,y,两个城市之间的距离为min(|a−c|,|b−d|),建造最短的路以便可以任意两个城市都可以到达。
思路:坐标离散化,将坐标先按照x排序,在按照,y排序,分别计算出城镇之间的距离大小
/*Du Jinzhi*/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <math.h>
#include <cstring>
#include <string>
#include <queue>
#include <deque>
#include <stack>
#include <stdlib.h>
#include <list>
#include <map>
#include <utility>
#include <set>
#include <bitset>
#include <vector>
#define pi acos(-1.0)
#define inf 0x3f3f3f3f
#define ll long long
#define linf 0x3f3f3f3f3f3f3f3fLL
using namespace std;
int cur=0;
struct node
{
ll x,y;
int w;
} pp[100005];
struct edge
{
ll u,v,w;
} e[100005];
int vis[100005];
bool cmp1(node a,node b)
{
return a.x<b.x;
}
void add(int u,int v,int w)
{
e[cur].u = u;
e[cur].v = v;
e[cur++].w =w;
}
bool cmp2(node a,node b)
{
return a.y<b.y;
}
bool cmp(edge a,edge b)
{
return a.w<b.w;
}
int find(int x)
{
if(vis[x]==x)
return vis[x];
return vis[x] = find(vis[x]);
}
int main()
{
int n;
scanf("%d",&n);
{
for(int i=1; i<=n; i++)
{
vis[i]=i;
scanf("%lld%lld",&pp[i].x,&pp[i].y);
pp[i].w=i;
}
sort(pp+1,pp+n+1,cmp1);
for(int i=2; i<=n; i++)
{
add(pp[i-1].w,pp[i].w,pp[i].x-pp[i-1].x);
}
sort(pp+1,pp+n+1,cmp2);
for(int i=2; i<=n; i++)
{
add(pp[i-1].w,pp[i].w,pp[i].y-pp[i-1].y);
}
sort(e,e+cur,cmp);
ll sum=0;
for(int i=0;i<cur;i++)
{
int fx=find(e[i].u);
int fy=find(e[i].v);
if(fx != fy)
{
vis[fx]=fy;
sum += e[i].w;
}
}
printf("%lld\n",sum);
}
return 0;
}