Dividing(多重背包,利用位二进制原理)

Dividing(多重背包,利用位二进制原理)

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.
The last line of the input file will be “0 0 0 0 0 0”; do not process this line.
Output
For each collection, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

题意: 给你6种价值不同的弹珠,每个都有个数,求能不能平分价值相同的弹珠

思路: 个数限制,明显多重背包问题,首先如果弹珠的总价值是奇数,那肯定是不能被平分的,如果为偶数,判断dp[sum/2]是否等于sum/2,相等即可平分,反之不能

多重背包的二进制优化:
【算法分析】
多重背包问题通常可转化成01背包问题求解。但若将每种物品的数量拆分成多个1的话,时间复杂度会很高,从而导致TLE。所以,需要利用二进制优化思想。即:
一个正整数n,可以被分解成1,2,4,…,2(k-1), n-2k+1 的形式。其中,k是满足n-2k+1>0的最大整数。

例如,假设给定价值为2,数量为10的物品,依据二进制优化思想可将10分解为1+2+4+3,则原来价值为2,数量为10的物品可等效转化为价值分别为 1* 2,2 * 2,4 * 2,3 * 2,即价值分别为2,4,8,6,数量均为1的物品。

二进制原文链接:https://blog.csdn.net/hnjzsyjyj/article/details/109363826

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[10],dp[210000],b[210000];//dp[i]表示容量为i时的最大价值
int main()
{
	int c=1;
	while(1)
	{
		int sum=0,s=0,i,j,x;
		memset(dp,-999999,sizeof(dp));//恰好全部装满 ,只有dp[0]时已知的
		dp[0]=0;
		memset(b,0,sizeof(b)); 
		for(i=1;i<=6;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i]*i;
		}
		if(sum==0)
		break;
		if(sum%2)
		{
			printf("Collection #%d:\nCan't be divided.\n\n",c++);
			continue;
		}
		j=0;
		for(i=1;i<=6;i++)
		{
			int k=1;
			while(a[i]>k)//二进制原理
			{
				b[j++]=k*i;
				a[i]=a[i]-k;
				k=k*2;
			}
			if(a[i])//有剩余
			b[j++]=a[i]*i;
		}
		for(i=0;i<j;i++)
		for(x=sum/2;x>=b[i];x--)
		dp[x]=max(dp[x],dp[x-b[i]]+b[i]);
		printf("Collection #%d:\n",c++);
		if(dp[sum/2]==sum/2)
		printf("Can be divided.\n\n");
		else
		printf("Can't be divided.\n\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值