1029. Median (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1029

题目:

1029. Median (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13

分析:

找出两个数组的共同中位数,可以用递归来做:先找出各自数组的中位数,然后比较,根据结果的大小(都是相异的数字,如果相同则直接就是中位数)来确定保留左边还是右边这段(当然原数组是排好序的),再接着对子串进行递归查找。

示例:

比如题目中的Sample,对于11 12 13 14,它的中位数是12,第二个数组9 10 15 16 17,它的中位数是15,因为15大于12,所以前者取后半部分13 14,后者取前半部分9 10 15,继续,前者中位数是13,后者中位数是10,13大于10,所以前者取前半部分13,后则会取后半部分10 15,因为前者只有一个数字13,把它和后者的剩余部分组成一个新的数组:10 13 15(排好序),中位数就可以用下标直接找到为13。

AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
long nums1[1000001];
long nums2[1000001];
long all[1000001];
bool cmp (long A, long B){
 return A < B;
}
int start, End, mid;
long *a;
long *b;
void find_Med(int s1, int e1, int s2, int e2){
 int m1 = (s1 + e1) / 2;
 int m2 = (s2 + e2) / 2;
 if (s1 == e1){//如果短数组只有一个数字,则记录其和长数组的两端下标返回
  mid = s1;
  start = s2;
  End = e2;
  return;
 }
 else if (a[m1] == b[m2]){//如果遇到两个数字相同,则其就是中位数
  mid = m1;
  start = m2;
  End = m2;
  return;
 }
 else if (a[m1] < b[m2]){//如果数组1的中位数小于数组2的中位数,取数组1的后半部分和数组2的前半部分继续查找
  find_Med(m1+ 1, e1, s2, e2 - m1 + s1 - 1);
 }
 else if (a[m1] > b[m2]){//如果数组1的中位数大于数组2的中位数,取数组1的前半部分和数组2的后半部分继续查找
  find_Med(s1, m1, s2 + e1 - m1, e2);
 }
}
int main(void){
 //freopen("F://Temp/input.txt", "r", stdin);
 int n1, n2;
 while (scanf("%d", &n1) != EOF){
  for (int i = 0; i < n1; i++){
   scanf("%ld", &nums1[i]);
  }
  scanf("%d", &n2);
  for (int i = 0; i < n2; i++){
   scanf("%ld", &nums2[i]);
  }
  int n_max, n_min;
  if (n1 <= n2){
   a = nums1;
   b = nums2;
   n_min = n1;
   n_max = n2;
  }
  else{
   a = nums2;
   b = nums1;
   n_min = n2;
   n_max = n1;
  }
  find_Med(0, n_min - 1, 0, n_max - 1);
  int i;
  for (i = 0; i < End - start + 1; i++){
   all[i] = b[start + i];
  }
  all[i] = a[mid];//把短数组的最后一个数插入到长数组的最后剩余一部分中
  sort(all, all + i + 1,cmp);//新组成的尾巴数组排序
  printf("%ld\n", all[i / 2]);
 }
 return 0;
}


截图:


——Apie陈小旭

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值