1029 Median (25 分)--PAT甲级

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.
Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.
Output Specification:

For each test case you should output the median of the two given sequences in a line.
Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

求两个有序数组的中位数。
根据计算,long int一般为4字节即4B,数组最大为200000,此时占用内存为4Bx200000x2=1600000/1024/1024=1.526MB,超过了内存限制,因此不能直接将两个数组输入存储。可以借助队列,第二个数组输入时每输入一个数,将a、b队列中最小的一个出队,直到出队元素数量达到中位数的位置。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<stack>
#include<set>
#include<unordered_map>
using namespace std;
const int maxn=10010;
const int inf=0x3fffffff;

int main()
{
    queue<int>a,b;
    int m,n,t;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&t);
        a.push(t);
    }
    scanf("%d",&m);
    int mid=(m+n-1)/2;
    int cnt=0;
    for(int i=0;i<m;i++){
        scanf("%d",&t);
        b.push(t);
        if(cnt<mid){
            if(!a.empty() && a.front()<t) a.pop();
            else b.pop();
            cnt++;
        }
    }
    for(;cnt<mid;cnt++){
        if(a.empty()) b.pop();
        else if(b.empty()) a.pop();
        else {
            if(a.front()>b.front()) b.pop();
            else a.pop();
        }
    }
    if(a.empty()) printf("%d",b.front());
    else if(b.empty()) printf("%d",a.front());
    else printf("%d",min(a.front(),b.front()));
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值