1046. Shortest Distance (20)

题目链接:http://www.patest.cn/contests/pat-a-practise/1046

题目:



时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

分析:

形成一个环路的路程长度比较:

前面都累加,然后比较s到j的距离s1和s到起点和t到终点的距离和再加上终点到起点的距离和s2的大小
distance[t] - distance[s] 和 distance[s] + distance[n + 1] + distance[n] - distance[t]

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main(){
 //freopen("F://Temp/input.txt", "r", stdin);
 int n, m;
 int distance[100002];
 cin >> n;
 memset(distance, 0, sizeof(distance));
 for (int i = 2; i <= n; i++){
  cin >> distance[i];
 }
 for (int i = 2; i <= n; i++){
  distance[i] += distance[i - 1];
 }
 cin >> distance[n + 1];
//前面都累加,但是最后一个是起点到终点的距离不用累加。
 cin >> m;
 for (int i = 0; i < m; i++){
  int s, t, min = 0x7fffffff;
  cin >> s >> t;
  if (s > t){
   int tmp = s;
   s = t;
   t = tmp;
  }
  if (distance[t] - distance[s] < distance[s] + distance[n + 1] + distance[n] - distance[t]){
   min = distance[t] - distance[s];
  }
  else min = distance[s] + distance[n + 1] + distance[n]- distance[t];
  cout << min << endl;
 }
 return 0;
}


截图:


——Apie陈小旭

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值