1098. Insertion or Heap Sort (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1098
题目:

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

分析:
和1089题相似

AC代码:
#include<cstdio>
#include<stack>
#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
int min(int a, int b){
 return a > b ? b : a;
}
bool same(const vector<int>&V1, const vector<int>&V2){//比较两个vector中的元素是否相同
 for (int i = 0; i < V1.size(); ++i){
  if (V1[i] != V2[i])
   return false;
 }
 return true;
}
void MaxHeapFixdown(vector<int>&original, int i, int n){//把一个节点沉下去,与比它大的最大的孩子节点交换
 int j, temp;
 temp =original[i];
 j = 2 * i + 1;
 while (j < n){
  if (j + 1 < n &&original[j + 1] >original[j])//在左右孩子中找最大的
   j++;
  if (original[j] <= temp)
   break;
  original[i] =original[j];//把较小的子结点往上移动,替换它的父结点  
  i = j;
  j = 2 * i + 1;
 }
 original[i] = temp;
}
void MakeMaxHeap(vector<int>&original){//建立大顶堆的过程,从下的第一个非叶子节点开始往下交换
 for (int i = original.size() / 2 - 1; i >= 0; i--){
  MaxHeapFixdown(original, i, original.size());
 }
}
vector<vector<int>>InsertSort_V;//存放插入排序每次的序列变化
vector<vector<int>>HeapSort_V;//存放归并排序每次的序列变化
void do_InsertSort(vector<int>original){//获取插入排序的每一次序列
 int length = original.size();
 for (int i = 1; i < length; ++i){//插入排序
  int j = i - 1;
  while (j >= 0 && original[j] > original[i]) --j;
  int temp = original[i];
  for (int k = i; k > j + 1; --k){
   original[k] = original[k - 1];
  }
  original[j + 1] = temp;
  if (InsertSort_V.size() == 0 || !same(InsertSort_V[InsertSort_V.size() - 1], original))
   //如果序列集为空,或者本次算法后序列有变化,才加入序列集
   InsertSort_V.push_back(original);
 }
}
void do_HeapSort(vector<int>original){//获取归并排序的每一次序列
 MakeMaxHeap(original);
 for (int i = original.size() - 1; i >= 1; i--){
  swap(original[i],original[0]);//堆排,每次把堆顶最大值放到下面,然后再往下交换
  MaxHeapFixdown(original, 0, i);
  HeapSort_V.push_back(original);
 }
}
void print(const vector<int>&V){//格式化打印序列
 for (int i = 0; i < V.size(); ++i){
  if (i == 0)cout << V[i];
  else cout << " " << V[i];
 }
 cout << endl;
}
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 int n;
 cin >> n;
 vector<int>input;
 vector<int>result;
 for (int i = 0; i < n; ++i){
  int num;
  cin >> num;
  input.push_back(num);
 }
 for (int i = 0; i < n; ++i){
  int num;
  cin >> num;
  result.push_back(num);
 }
 do_InsertSort(input);
 for (int i = 0; i < InsertSort_V.size(); ++i){
  if (same(InsertSort_V[i], result)){
   cout << "Insertion Sort" << endl;
   if (i == InsertSort_V.size() - 1)//如果是最后一个序列相等,那么下一个序列还是最后一个序列
    print(InsertSort_V[i]);
   else
    print(InsertSort_V[i + 1]);
   return 0;
  }
 }
 do_HeapSort(input);
 for (int i = 0; i < HeapSort_V.size(); ++i){
  if (same(HeapSort_V[i], result)){
   cout << "Heap Sort" << endl;
   if (i == HeapSort_V.size() - 1)//如果是最后一个序列相等,那么下一个序列还是最后一个序列
    print(HeapSort_V[i]);
   else
    print(HeapSort_V[i + 1]);
   return 0;
  }
 }
 return 0;
}


截图:

——Apie陈小旭
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值