PAT-A1098 Insertion or Heap Sort 题目内容及题解

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题目大意

题目给出整数的初始序列,以及某个排序方法多次迭代的结果序列,要求指出使用的是哪种排序方法,并且再运行此方法进行一次迭代,并在第二行输出结果序列。

解题思路

  1. 读入初始序列并将其排序做成测试序列,并读入第二个序列;
  2. 以倒序形式检查测试序列与排好序的序列,确定排序趟数(针对可能的堆排序)和排序种类;
  3. 如为堆排序则模拟堆排序过程产生下一趟排序的结果序列,如为插入排序则从头找排序趟数并产生下一趟排序的结果序列;
  4. 输出结果序列并返回零值。

代码

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

vector<int> Origin,Sorted,Test;
int N;
int Turn;

void Init(){
    int i,a;
    scanf("%d",&N);
    for(i=0;i<N;i++){
        scanf("%d",&a);
        Origin.push_back(a);
        Test.push_back(a);
    }
    sort(Test.begin(),Test.end());
    for(i=0;i<N;i++){
        scanf("%d",&a);
        Sorted.push_back(a);
    }
}

void downadjust(int low,int high){
    int i=low,j=2*i;
    while(j<=high){
        if(j+1<=high&&Sorted[j-1]<Sorted[j]){
            j++;
        }
        if(Sorted[i-1]<Sorted[j-1]){
            swap(Sorted[i-1],Sorted[j-1]);
            i=j;
            j=2*i;
        }else{
            break;
        }
    }
    
}

void HeapSort(){
    printf("Heap Sort\n");
    swap(Sorted[0],Sorted[N-Turn-1]);
    downadjust(1,N-Turn-1);
}

void InsertationSort(){
    printf("Insertion Sort\n");
    for(Turn=0;Turn<N-1;Turn++){
        if(Sorted[Turn]>Sorted[Turn+1]){
            break;
        }
    }
    sort(Sorted.begin(),Sorted.begin()+Turn+2);
}

void Check(){
    int i;
    for(i=N-1;i>0;i--){
        if(Sorted[i]!=Test[i]){
            break;
        }
        Turn++;
    }
    if(Sorted[0]==Test[i]){
        HeapSort();
    }else{
        InsertationSort();
    }
}

void Print(){
    int i;
    for(i=0;i<N;i++){
        printf("%d",Sorted[i]);
        if(i<N-1){
            printf(" ");
        }else{
            printf("\n");
        }
    }
}

int main(){
    Init();
    Check();
    Print();
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值