HDU 1496 Equation 哈希

Equations

Time Limit: 3000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0
     利用题中的公式求解出答案;如果是四个for 的话会超时,所以想到了用哈希;再把公式拆成俩个部分,a*i*i + b*j*j 与 -c*i*i - d*j*j  使这俩个数相等即可;再多用一个数组去存负数的情况;并且在a,b,c,d 同号时答案为零(样例1,1,1,1);



#include<stdio.h>
#include<iostream>
#include<string.h>
#define maxn 1000000     //最大值
using namespace std;
int Hash1[maxn];
int Hash2[maxn];
int i,j,ans;
int main()
{
    int a,b,c,d;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {
        memset(Hash1,0,sizeof(Hash1));
        memset(Hash2,0,sizeof(Hash2));
        if(a*b>0 && b*c>0 && c*d>0)          //同号答案0;
        {
            printf("0\n");
            continue;
        }
        for(i=1;i<=100;i++)                       
        {
            for(j=1;j<=100;j++)
            {
                int n = a*i*i+b*j*j;
                if(n>0) Hash1[n]++;       //用Hash1这个数组存正数;
                else Hash2[-n]++;         // 用Hash2来存负数,注意是 -n;
            }
        }
        ans = 0;
        for(i=1;i<=100;i++)
        {
            for(j=1;j<=100;j++)
            {
                int n = -c*i*i-d*j*j;
                if(n>0) ans+=Hash1[n];     //当n大于0时,把代表为正的数组加起来;

                else ans+=Hash2[-n];        //当n小于0时,把负值相加;
            }
        }
        printf("%d\n",16*ans);              //由于是平方,所以这4个值都有2种情况(不论 i 值正负 i*i 值都一样),所以要总数要乘16;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值