HDU 6103 Kirinriki【尺取法】【思维题】【好题】

19 篇文章 0 订阅
17 篇文章 0 订阅

Kirinriki

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 456    Accepted Submission(s): 160


Problem Description
We define the distance of two strings A and B with same length n is
disA,B=i=0n1|AiBn1i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T100
0m5000
Each character in the string is lowercase letter,  2|S|5000
|S|20000
 

Output
For each test case output one interge denotes the answer : the maximum length of the substring.
 

Sample Input
  
  
1 5 abcdefedcb
 

Sample Output
  
  
5
Hint
[0, 4] abcde [5, 9] fedcb The distance between them is abs('a' - 'b') + abs('b' - 'c') + abs('c' - 'd') + abs('d' - 'e') + abs('e' - 'f') = 5
 

Source

题意:

给出字符串s,寻找其两个长度相同且不重叠的子串,满足其每位的ascil差值之和不大于m,且长度最长。

思路:

因为字符串的长度为5000,所以可以枚举两个子串的对称轴,然后对其区间进行尺取法,这样只需要o(n^2)的复杂度即可。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 5010;

char a[maxn], num[maxn];
int m;

int solve(int len)
{
	int s = 0, t = 0, ans = 0, sum = 0;
	while (1)
	{
		while (sum + num[t] <= m && t < len)
		{
			sum += num[t];
			ans = max(t - s + 1, ans);
			t++;
		}
		sum -= num[s++];
		if (s >= len) break;
	}
	return ans;
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int len, res = 0;
		scanf("%d", &m);
		scanf("%s", a);
		len = strlen(a);
		for (int i = 0; i <= len; i++)	//枚举折的中点
		{
			int cnt = 0;
			for (int j = 1; j + i < len && i - j >= 0; j++)	//枚举奇数情况
				num[cnt++] = abs(a[j + i] - a[i - j]);
			res = max(res, solve(cnt));
		}
		for (int i = 0; i <= len; i++)	//枚举折的中点
		{
			int cnt = 0;
			for (int j = 1; j + i - 1 < len && i - j >= 0; j++)	//枚举偶数情况
				num[cnt++] = abs(a[j + i - 1] - a[i - j]);
			res = max(res, solve(cnt));
		}
		printf("%d\n", res);
	}
	return 0;
}




  • 4
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值